[packages] ptpd: fix initscript file name, fix description, add copyright header...
[openwrt/svn-archive/archive.git] / net / ptpd / Makefile
index 19d05c23b0bb97eeb4ca0edbe4b13a7f2ea231db..cbccb340bf97821b50dac94c5c330024e49be7e9 100644 (file)
@@ -1,8 +1,15 @@
+# 
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ptpd
 PKG_VERSION:=1.0.0
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ptpd
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ptpd
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ptpd
@@ -15,7 +22,7 @@ MAKE_PATH:=src
 define Package/ptpd
   SECTION:=net
   CATEGORY:=Network
 define Package/ptpd
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=PTPD
+  TITLE:=Precision Time protocol (PTP) daemon
   URL:=http://ptpd.sourceforge.net/
 endef
 
   URL:=http://ptpd.sourceforge.net/
 endef
 
@@ -27,7 +34,7 @@ endef
 define Package/ptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptpd $(1)/usr/sbin/
 define Package/ptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptpd $(1)/usr/sbin/
-       $(INSTALL_BIN) ./files/ptpd.init $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/ptpd.init $(1)/etc/init.d/ptpd
 endef
 
 $(eval $(call BuildPackage,ptpd))
 endef
 
 $(eval $(call BuildPackage,ptpd))