update php-apc to 3.0.16, disable pthread mutex's as they are on by default now.
[openwrt/svn-archive/archive.git] / net / pure-ftpd / Makefile
index 1eef3fc3843faa98b66292f9cddab5acd7878509..d05172130cdc31c7acf2448f32f57ce7045e1238 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,40 +10,40 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=pure-ftpd
 PKG_VERSION:=1.0.21
 PKG_RELEASE:=1
-PKG_MD5SUM:=ca8a8dbec0cd9c8ea92fc4c37ea9c410
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-
-PKG_CAT:=bzcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases/
+PKG_MD5SUM:=ca8a8dbec0cd9c8ea92fc4c37ea9c410
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pure-ftpd
+  SUBMENU:=FTP
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libelf
   TITLE:=Secure FTP made easy!
-  DESCRIPTION:=\
-       Pure-FTPd is a free (BSD), secure, production-quality and standard-conformant FTP server.\
-       It doesn't provide useless bells and whistles, but focuses on efficiency and ease of use.\
-       It provides simple answers to common needs, plus unique useful features for personal users\
-       as well as hosting providers.
   URL:=http://www.pureftpd.org/project/pure-ftpd
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,--with-everything)
+define Package/pure-ftpd/description
+ Pure-FTPd is a free (BSD), secure, production-quality and standard-conformant
+ FTP server. It doesn't provide useless bells and whistles, but focuses on
+ efficiency and ease of use.
+ It provides simple answers to common needs, plus unique  useful features for
+ personal users as well as hosting providers.
 endef
 
+CONFIGURE_ARGS += \
+       --with-everything \
+
 define Package/pure-ftpd/install
-       $(INSTALL_DIR) $(1)/etc/init.d $(1)/usr/sbin
-       install -m0755 ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
-       $(CP) $(PKG_BUILD_DIR)/src/pure-{ftpd,pw,ftpwho,mrtginfo,pwconvert,quotacheck,statsdecode,uploadscript,authd} $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d $(1)/usr/sbin
+       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin
+       $(INSTALL_BIN) $(foreach i,ftpd pw ftpwho mrtginfo pwconvert quotacheck statsdecode uploadscript authd, \
+               $(PKG_BUILD_DIR)/src/pure-$(i)) $(1)/usr/sbin
 endef
 
 $(eval $(call BuildPackage,pure-ftpd))