[packages] quagga-unstable: Update to v0.99.14 and refresh patches
[openwrt/svn-archive/archive.git] / net / quagga-unstable / Makefile
index 7e7425dbe3c4180c0284dc6706ca00dfd8478bff..087846dad5bde56237fd67bb392ce13b083e6193 100644 (file)
@@ -1,17 +1,16 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12175 2008-08-05 22:04:10Z florian $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga-unstable
-PKG_VERSION:=0.99.11
+PKG_VERSION:=0.99.14
 PKG_RELEASE:=1
-PKG_MD5SUM:=903e40c744730ad4d62bee872eeb813b
+PKG_MD5SUM:=3a075fd5e26ec6d52f4a51b14a2d3c2c
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
                 http://www.de.quagga.net/download/ \
@@ -31,15 +30,14 @@ endef
 
 define Package/quagga-unstable
   $(call Package/quagga-unstable/Default)
-  DEPENDS:=
+  DEPENDS:= +librt
   MENU:=1
 endef
 
 define Package/quagga-unstable/description
-       A routing software package that provides TCP/IP based routing services
-       with routing protocols support such as RIPv1, RIPv2, RIPng, OSPFv2,
-       OSPFv3, BGP-4, and BGP-4+
-
+  A routing software package that provides TCP/IP based routing services
+  with routing protocols support such as RIPv1, RIPv2, RIPng, OSPFv2,
+  OSPFv3, BGP-4, and BGP-4+
 endef
 
 define Package/quagga-unstable-libzebra
@@ -108,19 +106,20 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR=$(PKG_INSTALL_DIR) \
                all install
 endef
 
-define Package/quagga-unstable/install 
+define Package/quagga-unstable/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/watchquagga $(1)/usr/sbin/
        # avoid /etc being set to 0750
        $(INSTALL_DIR) $(1)/etc/quagga/
        chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/zebra.conf
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/quagga $(1)/usr/sbin/quagga.init
        $(INSTALL_BIN) ./files/quagga.init $(1)/etc/init.d/quagga
@@ -129,10 +128,10 @@ endef
 
 define Package/quagga-unstable/postinst
 #!/bin/sh
-  
+
 name=quagga
 id=51
-  
+
 # do not change below
 # check if we are on real system
 if [ -z "$${IPKG_INSTROOT}" ]; then
@@ -151,18 +150,18 @@ if [ -z "$${IPKG_INSTROOT}" ]; then
 fi
 
 echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then 
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
        echo "adding group $$name to /etc/group"
-       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group  
+       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
 fi
 
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then 
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
        echo "adding user $$name to /etc/passwd"
        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 
 grep -q '^zebra[[:space:]]*2601/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-if [ $$? -ne 0 ]; then  
+if [ $$? -ne 0 ]; then
 echo "zebrasrv      2600/tcp" >>$${IPKG_INSTROOT}/etc/services
 echo "zebra         2601/tcp" >>$${IPKG_INSTROOT}/etc/services
 echo "ripd          2602/tcp" >>$${IPKG_INSTROOT}/etc/services
@@ -175,37 +174,55 @@ echo "isisd         2608/tcp" >>$${IPKG_INSTROOT}/etc/services
 fi
 endef
 
-define Package/quagga-unstable-bgpd/install    
+define Package/quagga-unstable-bgpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/bgpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/bgpd.conf
 endef
 
 define Package/quagga-unstable-isisd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/isisd $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/isisd.conf
 endef
 
-define Package/quagga-unstable-ospfd/install   
+define Package/quagga-unstable-ospfd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ospfd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ospfd.conf
 endef
 
-define Package/quagga-unstable-ospf6d/install  
+define Package/quagga-unstable-ospf6d/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ospf6d $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ospf6d.conf
 endef
 
-define Package/quagga-unstable-ripd/install    
+define Package/quagga-unstable-ripd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ripd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ripd.conf
 endef
 
-define Package/quagga-unstable-ripngd/install  
+define Package/quagga-unstable-ripngd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ripngd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga/
+       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ripngd.conf
 endef
 
-define Package/quagga-unstable-vtysh/install   
+define Package/quagga-unstable-vtysh/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vtysh $(1)/usr/bin/
 endef