[packages] quagga-unstable: Update to v0.99.16
[openwrt/svn-archive/archive.git] / net / quagga-unstable / Makefile
index 16198e41ce7870d9f09d93441620d2fabe0f7d61..78edca4894ed0b801974dbd6e3dfbe98841f8f41 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,23 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga-unstable
-PKG_VERSION:=0.99.13
+PKG_VERSION:=0.99.16
 PKG_RELEASE:=1
-PKG_MD5SUM:=55a7d2dcf016580a7c7412b3518cd942
 
+PKG_SOURCE:=quagga-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
                 http://www.de.quagga.net/download/ \
                 http://www.uk.quagga.net/download/
-PKG_SOURCE:=quagga-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=350fb150be526cdfc4d2b093cb4d69a7
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/quagga-$(PKG_VERSION)
 
+PKG_CONFIG_DEPENDS:= \
+       CONFIG_PACKAGE_quagga-unstable-isisd \
+       CONFIG_PACKAGE_quagga-unstable-ripngd
+
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/quagga-unstable/Default
@@ -52,7 +59,7 @@ endef
 
 define Package/quagga-unstable-bgpd
   $(call Package/quagga-unstable/Default)
-  DEPENDS += quagga-unstable-libzebra
+  DEPENDS+= +quagga-unstable-libzebra
   TITLE:=BGPv4, BGPv4+, BGPv4- routing engine
 endef
 
@@ -63,67 +70,64 @@ endef
 
 define Package/quagga-unstable-ospfd
   $(call Package/quagga-unstable/Default)
-  DEPENDS += quagga-unstable-libospf quagga-unstable-libzebra
+  DEPENDS+= +quagga-unstable-libospf +quagga-unstable-libzebra
   TITLE:=OSPFv2 routing engine
 endef
 
 define Package/quagga-unstable-ospf6d
   $(call Package/quagga-unstable/Default)
-  DEPENDS += quagga-unstable-libospf quagga-unstable-libzebra
+  DEPENDS+= +quagga-unstable-libospf +quagga-unstable-libzebra @IPV6
   TITLE:=OSPFv3 routing engine
 endef
 
 define Package/quagga-unstable-ripd
   $(call Package/quagga-unstable/Default)
-  DEPENDS += quagga-unstable-libzebra
+  DEPENDS+= +quagga-unstable-libzebra
   TITLE:=RIP routing engine
 endef
 
 define Package/quagga-unstable-ripngd
   $(call Package/quagga-unstable/Default)
-  DEPENDS += quagga-unstable-libzebra
+  DEPENDS+= +quagga-unstable-libzebra @BROKEN
   TITLE:=RIPNG routing engine
 endef
 
 define Package/quagga-unstable-vtysh
   $(call Package/quagga-unstable/Default)
-  DEPENDS += quagga-unstable-libzebra +libreadline +libncurses
+  DEPENDS+= quagga-unstable-libzebra +libreadline +libncurses
   TITLE:=integrated shell for Quagga routing software
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --localstatedir=/var/run/quagga \
-               --sysconfdir=/etc/quagga/ \
-               --enable-shared \
-               --disable-static \
-               --enable-ipv6 \
-               --enable-vtysh \
-               --enable-user=quagga \
-               --enable-group=quagga \
-               --enable-multipath=8 \
-               --enable-isisd \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --localstatedir=/var/run/quagga \
+       --sysconfdir=/etc/quagga/ \
+       --enable-shared \
+       --disable-static \
+       --enable-vtysh \
+       --enable-user=quagga \
+       --enable-group=quagga \
+       --enable-pie=no \
+       --enable-multipath=8 \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               all install
-endef
+ifneq ($(CONFIG_PACKAGE_quagga-unstable-isisd),)
+  CONFIGURE_ARGS+= --enable-isisd
+endif
+
+ifneq ($(CONFIG_PACKAGE_quagga-unstable-ripngd),)
+  CONFIGURE_ARGS+= --enable-ripngd
+endif
 
 define Package/quagga-unstable/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/watchquagga $(1)/usr/sbin/
        # avoid /etc being set to 0750
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/zebra.conf
-       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/quagga $(1)/usr/sbin/quagga.init
        $(INSTALL_BIN) ./files/quagga.init $(1)/etc/init.d/quagga
-       $(INSTALL_DIR) $(1)/var/run/quagga
 endef
 
 define Package/quagga-unstable/postinst
@@ -177,48 +181,48 @@ endef
 define Package/quagga-unstable-bgpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/bgpd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/bgpd.conf
 endef
 
 define Package/quagga-unstable-isisd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/isisd $(1)/usr/sbin
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/isisd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/isisd.conf
 endef
 
 define Package/quagga-unstable-ospfd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ospfd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ospfd.conf
 endef
 
 define Package/quagga-unstable-ospf6d/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ospf6d $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ospf6d.conf
 endef
 
 define Package/quagga-unstable-ripd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ripd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ripd.conf
 endef
 
 define Package/quagga-unstable-ripngd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ripngd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/quagga/
-       chmod 0750 $(1)/etc/quagga/
+       $(INSTALL_DIR) $(1)/etc/quagga
+       chmod 0750 $(1)/etc/quagga
        $(INSTALL_DATA) ./files/quagga.conf $(1)/etc/quagga/ripngd.conf
 endef
 
@@ -234,7 +238,7 @@ endef
 
 define Package/quagga-unstable-libzebra/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libzebra.so.* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libzebra.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,quagga-unstable))