quagga: remove the postinst script
[openwrt/svn-archive/archive.git] / net / quagga / Makefile
index 42ad5b467874caf0ff1ee4710488225530285d08..217238c06aa904686fbfcc920fe3630ae26ed2ea 100644 (file)
@@ -165,8 +165,8 @@ CONFIGURE_ARGS+= \
        --sysconfdir=/etc/quagga/ \
        --enable-shared \
        --disable-static \
-       --enable-user=quagga \
-       --enable-group=quagga \
+       --enable-user=network \
+       --enable-group=network \
        --enable-pie=no \
        --enable-multipath=8 \
        $(call autoconf_bool,CONFIG_PACKAGE_quagga-libzebra,zebra) \
@@ -201,54 +201,6 @@ define Package/quagga/install
        $(INSTALL_BIN) ./files/quagga.init $(1)/etc/init.d/quagga
 endef
 
-define Package/quagga/postinst
-#!/bin/sh
-
-name=quagga
-id=51
-
-# do not change below
-# check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-       # create copies of passwd and group, if we use squashfs
-       rootfs=`mount |awk '/root/ { print $$5 }'`
-       if [ "$$rootfs" = "squashfs" ]; then
-               if [ -h /etc/group ]; then
-                       rm /etc/group
-                       cp /rom/etc/group /etc/group
-               fi
-               if [ -h /etc/passwd ]; then
-                       rm /etc/passwd
-                       cp /rom/etc/passwd /etc/passwd
-               fi
-       fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-       echo "adding group $$name to /etc/group"
-       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-       echo "adding user $$name to /etc/passwd"
-       echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-
-grep -q '^zebra[[:space:]]*2601/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-if [ $$? -ne 0 ]; then
-echo "zebrasrv      2600/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "zebra         2601/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "ripd          2602/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "ripngd        2603/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "ospfd         2604/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "bgpd          2605/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "ospf6d        2606/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "ospfapi       2607/tcp" >>$${IPKG_INSTROOT}/etc/services
-echo "isisd         2608/tcp" >>$${IPKG_INSTROOT}/etc/services
-fi
-endef
-
 define Package/quagga-bgpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/bgpd $(1)/usr/sbin/