replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / radvd / Makefile
index 2ee47a20d547fdf7428caaac61c11f8731ba560c..b7f3c0bee21c34a862ebdc20127508277efda7d2 100644 (file)
@@ -76,13 +76,13 @@ define Build/Compile
 endef
 
 define Package/radvd/install
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/radvd.conf $(1)/etc/radvd.conf
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/radvd.init $(1)/etc/init.d/radvd
-       install -d -m0755 $(1)/usr/sbin
-       install -m 755 $(PKG_INSTALL_DIR)/usr/sbin/radvd $(1)/usr/sbin/
-       install -m 755 $(PKG_INSTALL_DIR)/usr/sbin/radvdump $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/radvd.conf $(1)/etc/radvd.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/radvd.init $(1)/etc/init.d/radvd
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radvd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radvdump $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,radvd))