Add nufw
[openwrt/svn-archive/archive.git] / net / rp-l2tp / Makefile
index 6c77c4934fc40e1a5e7f0d7744af70c9b700aeaf..1748a447cffd2f4b6e184eda88468c13121cc08d 100644 (file)
@@ -46,19 +46,19 @@ define Package/rp-l2tpd/install
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tp.conf.example $(1)/etc/l2tp.conf
        $(INSTALL_DIR) $(1)/usr/lib/l2tp
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rp-l2tpd.init $(1)/etc/init.d/rp-l2tpd
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 endef
 
 #define Package/rp-l2tpd-mod-cmd/install       
 #      $(INSTALL_DIR) $(1)/usr/lib/l2tp
 #      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
 #      $(INSTALL_DIR) $(1)/usr/sbin
-#      $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+#      $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 #endef
 
 #define Package/rp-l2tpd-mod-ppp/install