Merge pluggable handlers into the main rp-l2tp ipkg package.
[openwrt/svn-archive/archive.git] / net / rp-l2tp / Makefile
index 12eaa616fe624a5056191ffc3a587d783341746d..1f286e246aabf57c2c0a06220615b962914d3c1f 100644 (file)
@@ -33,21 +33,20 @@ endef
 
 define Package/rp-l2tpd
   $(call Package/rp-l2tpd/Default)
+#      DEPENDS:=+rp-l2tpd-mod-cmd +rp-l2tpd-mod-ppp
   TITLE+= daemon
-  MENU:=1
+#  MENU:=1
 endef
 
-define Package/rp-l2tpd-mod-cmd
-  $(call Package/rp-l2tpd/Default)
-  DEPENDS:=rp-l2tpd
-  TITLE:=Simple command handler for the RR L2TP daemon
-endef
+#define Package/rp-l2tpd-mod-cmd
+#  $(call Package/rp-l2tpd/Default)
+#  TITLE:=Simple command handler for the RR L2TP daemon
+#endef
 
-define Package/rp-l2tpd-mod-ppp
-  $(call Package/rp-l2tpd/Default)
-  DEPENDS:=rp-l2tpd
-  TITLE:=PPP handler for the RR L2TP daeomon
-endef
+#define Package/rp-l2tpd-mod-ppp
+#  $(call Package/rp-l2tpd/Default)
+#  TITLE:=PPP handler for the RR L2TP daeomon
+#endef
 
 # uses GNU configure
 MAKE_FLAGS += \
@@ -64,20 +63,23 @@ define Package/rp-l2tpd/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rp-l2tpd.init $(1)/etc/init.d/rp-l2tpd
-endef
-
-define Package/rp-l2tpd-mod-cmd/install        
-       $(INSTALL_DIR) $(1)/usr/lib/l2tp
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
-       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 endef
 
-define Package/rp-l2tpd-mod-ppp/install
-       $(INSTALL_DIR) $(1)/usr/lib/l2tp
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
-endef
+#define Package/rp-l2tpd-mod-cmd/install       
+#      $(INSTALL_DIR) $(1)/usr/lib/l2tp
+#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
+#      $(INSTALL_DIR) $(1)/usr/sbin
+#      $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+#endef
+
+#define Package/rp-l2tpd-mod-ppp/install
+#      $(INSTALL_DIR) $(1)/usr/lib/l2tp
+#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
+#endef
 
 $(eval $(call BuildPackage,rp-l2tpd))
-$(eval $(call BuildPackage,rp-l2tpd-mod-cmd))
-$(eval $(call BuildPackage,rp-l2tpd-mod-ppp))
+#$(eval $(call BuildPackage,rp-l2tpd-mod-cmd))
+#$(eval $(call BuildPackage,rp-l2tpd-mod-ppp))