make xmms compatible to new pkg_install_files parameter
[openwrt/svn-archive/archive.git] / net / rp-l2tp / Makefile
index 37ea89eb6c4335114dcafd4ef804a481090c2449..1f286e246aabf57c2c0a06220615b962914d3c1f 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=rp-l2tp
 PKG_VERSION:=0.4
 PKG_RELEASE:=1
-PKG_MD5SUM:=0e45d11cb4fa6c56cce6b1d119733ed9
 
-PKG_SOURCE_URL:=@SF/rp-l2tp
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/rp-l2tp
+PKG_MD5SUM:=0e45d11cb4fa6c56cce6b1d119733ed9
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -22,57 +22,64 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/rp-l2tpd
+define Package/rp-l2tpd/Default
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=an L2TP (Layer 2 Tunneling Protocol) daemon
-  DESCRIPTION:=An L2TP (Layer 2 Tunneling Protocol) daemon.
+  TITLE:=Roaring Penguin L2TP
+  DESCRIPTION:=\
+       Roaring Penguin L2TP (Layer 2 Tunneling Protocol) implementation.
   URL:=http://sourceforge.net/projects/rp-l2tp/
-  MENU:=1
 endef
 
-define Package/rp-l2tpd-mod-cmd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=rp-l2tpd
-  TITLE:=a simple command handler for the L2TP daemon
+define Package/rp-l2tpd
+  $(call Package/rp-l2tpd/Default)
+#      DEPENDS:=+rp-l2tpd-mod-cmd +rp-l2tpd-mod-ppp
+  TITLE+= daemon
+#  MENU:=1
 endef
 
-define Package/rp-l2tpd-mod-ppp
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=rp-l2tpd
-  TITLE:=a PPP handler for the L2TP daeomon
-endef
+#define Package/rp-l2tpd-mod-cmd
+#  $(call Package/rp-l2tpd/Default)
+#  TITLE:=Simple command handler for the RR L2TP daemon
+#endef
 
-define Build/Compile
-  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
-endef
+#define Package/rp-l2tpd-mod-ppp
+#  $(call Package/rp-l2tpd/Default)
+#  TITLE:=PPP handler for the RR L2TP daeomon
+#endef
+
+# uses GNU configure
+MAKE_FLAGS += \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install
+
+TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/libevent $(TARGET_CFLAGS)
 
 define Package/rp-l2tpd/install        
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tp.conf.example $(1)/etc/l2tp.conf
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/rp-l2tpd.init $(1)/etc/init.d/rp-l2tpd
-       install -d -m0755 $(1)/usr/lib/l2tp
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/lib/l2tp
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
-endef
-
-define Package/rp-l2tpd-mod-cmd/install        
-       install -d -m0755 $(1)/usr/lib/l2tp
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/rp-l2tpd.init $(1)/etc/init.d/rp-l2tpd
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
-endef
-
-define Package/rp-l2tpd-mod-ppp/install
-       install -d -m0755 $(1)/usr/lib/l2tp
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 endef
 
-$(eval $(call BuildPackage,rp-l2tpd))
-$(eval $(call BuildPackage,rp-l2tpd-mod-cmd))
-$(eval $(call BuildPackage,rp-l2tpd-mod-ppp))
+#define Package/rp-l2tpd-mod-cmd/install       
+#      $(INSTALL_DIR) $(1)/usr/lib/l2tp
+#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
+#      $(INSTALL_DIR) $(1)/usr/sbin
+#      $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+#endef
 
+#define Package/rp-l2tpd-mod-ppp/install
+#      $(INSTALL_DIR) $(1)/usr/lib/l2tp
+#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
+#endef
 
+$(eval $(call BuildPackage,rp-l2tpd))
+#$(eval $(call BuildPackage,rp-l2tpd-mod-cmd))
+#$(eval $(call BuildPackage,rp-l2tpd-mod-ppp))