packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / rp-l2tp / Makefile
index 4e9f22750eedb180c221809d8807341448c31e12..d7942faa026c4266e1db4f5487da11f6337de6d3 100644 (file)
@@ -1,24 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-l2tp
 PKG_VERSION:=0.4
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rp-l2tp
 PKG_MD5SUM:=0e45d11cb4fa6c56cce6b1d119733ed9
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,31 +32,30 @@ define Package/rp-l2tpd/description
        Roaring Penguin L2TP (Layer 2 Tunneling Protocol) implementation.
 endef
 
-# uses GNU configure
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-
 TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/libevent $(TARGET_CFLAGS)
 
-define Package/rp-l2tpd/install        
+define Package/rp-l2tpd/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tp.conf.example $(1)/etc/l2tp.conf
        $(INSTALL_DIR) $(1)/usr/lib/l2tp
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/rp-l2tpd.init $(1)/etc/init.d/rp-l2tpd
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/sync-pppd.so $(1)/usr/lib/l2tp/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+endef
+
+define Package/rp-l2tpd/conffiles
+/etc/l2tp.conf
 endef
 
-#define Package/rp-l2tpd-mod-cmd/install       
+#define Package/rp-l2tpd-mod-cmd/install
 #      $(INSTALL_DIR) $(1)/usr/lib/l2tp
 #      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
 #      $(INSTALL_DIR) $(1)/usr/sbin
-#      $(CP) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
+#      $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 #endef
 
 #define Package/rp-l2tpd-mod-ppp/install