Fix install permissions and executable bits for rp-pppoe (#2882)
[openwrt/svn-archive/archive.git] / net / rp-pppoe / Makefile
index 35b1e709812f0f75a866f3028ae1071d00b2a822..249084a15f5ec759f0f9d5a34f59c25ed1c0bd7c 100644 (file)
@@ -13,9 +13,8 @@ PKG_VERSION:=3.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://roaringpenguin.com/penguin/pppoe/
+PKG_SOURCE_URL:=http://roaringpenguin.com/files/download
 PKG_MD5SUM:=0e32760f498f9cde44081ee6aafc823b
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -28,8 +27,9 @@ define Package/rp-pppoe/Default
   DEPENDS:=+ppp
   TITLE:=PPPoE (PPP over Ethernet)
   URL:=http://roaringpenguin.com/penguin/pppoe/
+  SUBMENU:=dial-in/up
 endef
-  
+
 define Package/rp-pppoe-client
   $(call Package/rp-pppoe/Default)
   TITLE+= client
@@ -50,18 +50,11 @@ define Package/rp-pppoe-sniff
   TITLE+= sniffer
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,, \
-               ac_cv_path_PPPD=/usr/sbin/pppd, \
-               src \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               RPM_INSTALL_ROOT="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/src/libevent
+CONFIGURE_PATH := ./src
+CONFIGURE_ARGS += ac_cv_path_PPPD=/usr/sbin/pppd
+MAKE_FLAGS := RPM_INSTALL_ROOT="$(PKG_INSTALL_DIR)" install
+MAKE_PATH := ./src
 
 define Package/rp-pppoe-client/install 
        $(INSTALL_DIR) $(1)/etc/init.d
@@ -69,7 +62,11 @@ define Package/rp-pppoe-client/install
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-connect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-start $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-stop $(1)/usr/sbin/
+       $(SED) 's,modprobe,insmod,g' $(1)/usr/sbin/pppoe-connect
 endef
 
 define Package/rp-pppoe-relay/install  
@@ -78,7 +75,7 @@ define Package/rp-pppoe-relay/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/pppoe-relay.init $(1)/etc/init.d/pppoe-relay
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-relay $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-relay $(1)/usr/sbin/
 endef
 
 define Package/rp-pppoe-server/install 
@@ -89,12 +86,12 @@ define Package/rp-pppoe-server/install
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe-server-options $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-server $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-server $(1)/usr/sbin/
 endef
 
 define Package/rp-pppoe-sniff/install  
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-sniff $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-sniff $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,rp-pppoe-client))