[packages] rp-pppoe-server (src:rp-pppoe): Identified two conffiles that should be...
[openwrt/svn-archive/archive.git] / net / rp-pppoe / Makefile
index d3da4871f022ccfc2e2c3b91fbf382252e39cce1..9d58fe7fe82f046cb529dd1402119842f9d40699 100644 (file)
@@ -4,21 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-pppoe
-PKG_VERSION:=3.8
+PKG_VERSION:=3.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://roaringpenguin.com/files/download
-PKG_MD5SUM:=0e32760f498f9cde44081ee6aafc823b
-PKG_CAT:=zcat
+PKG_MD5SUM:=d58a13cc4185bca6121a606ff456dec0
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=ppp
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,34 +24,64 @@ define Package/rp-pppoe/Default
   CATEGORY:=Network
   DEPENDS:=+ppp
   TITLE:=PPPoE (PPP over Ethernet)
-  URL:=http://roaringpenguin.com/penguin/pppoe/
+  URL:=http://roaringpenguin.com/products/pppoe
   SUBMENU:=dial-in/up
 endef
 
+define Package/rp-pppoe/Default/description
+       Dubbed RP-PPPoE, this open-source product is ideal for Linux users with
+       a DSL "modem" whose Internet service provider uses PPPoE.
+endef
+
 define Package/rp-pppoe-client
   $(call Package/rp-pppoe/Default)
   TITLE+= client
 endef
 
+define Package/rp-pppoe-client/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-connect.
+endef
+
 define Package/rp-pppoe-relay
   $(call Package/rp-pppoe/Default)
   TITLE+= relay
 endef
 
+define Package/rp-pppoe-relay/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-relay.
+endef
+
 define Package/rp-pppoe-server
   $(call Package/rp-pppoe/Default)
   TITLE+= server
 endef
 
+define Package/rp-pppoe-server/conffiles
+/etc/ppp/pppoe-server-options
+/etc/default/pppoe-server
+endef
+
+define Package/rp-pppoe-server/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-server.
+endef
+
 define Package/rp-pppoe-sniff
   $(call Package/rp-pppoe/Default)
   TITLE+= sniffer
 endef
 
+define Package/rp-pppoe-sniff/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-sniff.
+endef
+
 TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/src/libevent
 CONFIGURE_PATH := ./src
-CONFIGURE_ARGS += ac_cv_path_PPPD=/usr/sbin/pppd
-MAKE_FLAGS := RPM_INSTALL_ROOT="$(PKG_INSTALL_DIR)" install
+CONFIGURE_ARGS += ac_cv_path_PPPD=/usr/sbin/pppd --enable-plugin=$(STAGING_DIR)/usr/include/
+MAKE_FLAGS := DESTDIR="$(PKG_INSTALL_DIR)" install
 MAKE_PATH := ./src
 
 define Package/rp-pppoe-client/install 
@@ -63,8 +90,10 @@ define Package/rp-pppoe-client/install
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{connect,start,stop} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-connect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-start $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-stop $(1)/usr/sbin/
        $(SED) 's,modprobe,insmod,g' $(1)/usr/sbin/pppoe-connect
 endef
 
@@ -74,7 +103,7 @@ define Package/rp-pppoe-relay/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/pppoe-relay.init $(1)/etc/init.d/pppoe-relay
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-relay $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-relay $(1)/usr/sbin/
 endef
 
 define Package/rp-pppoe-server/install 
@@ -83,14 +112,16 @@ define Package/rp-pppoe-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/pppoe-server.init $(1)/etc/init.d/pppoe-server
        $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DIR) $(1)/etc/ppp/plugins
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe-server-options $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-server $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-server $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/ppp/plugins/rp-pppoe.so $(1)/etc/ppp/plugins/
 endef
 
 define Package/rp-pppoe-sniff/install  
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-sniff $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-sniff $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,rp-pppoe-client))