Update tinyproxy to 1.6.4 (#4007)
[openwrt/svn-archive/archive.git] / net / rp-pppoe / Makefile
index 67dc23fbbb89b603342f78e60af71e8299c37522..c415ff04583df7f3b7518f94567c581a51fe23de 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-pppoe
-PKG_VERSION:=3.8
+PKG_VERSION:=3.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://roaringpenguin.com/files/download
-PKG_MD5SUM:=0e32760f498f9cde44081ee6aafc823b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=7693f289c3babcfe211a9deef9118c6f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,30 +23,55 @@ define Package/rp-pppoe/Default
   CATEGORY:=Network
   DEPENDS:=+ppp
   TITLE:=PPPoE (PPP over Ethernet)
-  URL:=http://roaringpenguin.com/penguin/pppoe/
+  URL:=http://roaringpenguin.com/products/pppoe
   SUBMENU:=dial-in/up
 endef
 
+define Package/rp-pppoe/Default/description
+       Dubbed RP-PPPoE, this open-source product is ideal for Linux users with
+       a DSL "modem" whose Internet service provider uses PPPoE.
+endef
+
 define Package/rp-pppoe-client
   $(call Package/rp-pppoe/Default)
   TITLE+= client
 endef
 
+define Package/rp-pppoe-client/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-connect.
+endef
+
 define Package/rp-pppoe-relay
   $(call Package/rp-pppoe/Default)
   TITLE+= relay
 endef
 
+define Package/rp-pppoe-relay/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-relay.
+endef
+
 define Package/rp-pppoe-server
   $(call Package/rp-pppoe/Default)
   TITLE+= server
 endef
 
+define Package/rp-pppoe-server/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-server.
+endef
+
 define Package/rp-pppoe-sniff
   $(call Package/rp-pppoe/Default)
   TITLE+= sniffer
 endef
 
+define Package/rp-pppoe-sniff/description
+        $(call Package/rp-pppoe/Default/description)
+        This package contains pppoe-sniff.
+endef
+
 TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/src/libevent
 CONFIGURE_PATH := ./src
 CONFIGURE_ARGS += ac_cv_path_PPPD=/usr/sbin/pppd
@@ -62,8 +84,10 @@ define Package/rp-pppoe-client/install
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{connect,start,stop} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-connect $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-start $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/pppoe-stop $(1)/usr/sbin/
        $(SED) 's,modprobe,insmod,g' $(1)/usr/sbin/pppoe-connect
 endef
 
@@ -73,7 +97,7 @@ define Package/rp-pppoe-relay/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/pppoe-relay.init $(1)/etc/init.d/pppoe-relay
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-relay $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-relay $(1)/usr/sbin/
 endef
 
 define Package/rp-pppoe-server/install 
@@ -84,12 +108,12 @@ define Package/rp-pppoe-server/install
        $(INSTALL_DIR) $(1)/etc/ppp
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe-server-options $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-server $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-server $(1)/usr/sbin/
 endef
 
 define Package/rp-pppoe-sniff/install  
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-sniff $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppoe-sniff $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,rp-pppoe-client))