[net] File Transfer: Moved old FTP category and combined with other file transfer...
[openwrt/svn-archive/archive.git] / net / rsync / Makefile
index 8fc225edf2778709d68325c6f6b8fc14fb3e9a8e..0a7aa2ee387bf4966e8cc754615dab44130d1e26 100644 (file)
@@ -1,33 +1,36 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
-PKG_VERSION:=3.0.3
-PKG_RELEASE:=2
+PKG_VERSION:=3.0.7
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync
-PKG_MD5SUM:=16d41aab9ece435198af222c5415a304
+PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
+PKG_MD5SUM:=b53525900817cf1ba7ad3a516ab5bfe9
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rsync
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=File Transfer
   TITLE:=Fast remote file copy program (like rcp)
   DEPENDS:=+libpopt
   URL:=http://rsync.samba.org/
 endef
 
 define Package/rsync/description
-       sync is a program that allows files to be copied to
+       rsync is a program that allows files to be copied to
        and from remote machines in much the same way as rcp.
        It has many more options than rcp, and uses the rsync
        remote-update protocol to greatly speed up file
@@ -47,7 +50,7 @@ CONFIGURE_ARGS += \
 
 define Package/rsync/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rsync))