packages: Upgrade rsync to 3.0.2
[openwrt/svn-archive/archive.git] / net / rsync / Makefile
index a1170f6f2dd4a45333b9ba6484027ec4e1e883d4..1dcd0b96bd43b7ad638f5564802827161d93bc72 100644 (file)
@@ -1,41 +1,55 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # $Id$
 #
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
-PKG_VERSION:=2.6.9
+PKG_VERSION:=3.0.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync
-PKG_MD5SUM:=996d8d8831dbca17910094e56dcb5942
+PKG_MD5SUM:=fd4c5d77d8cb7bb86ab209076fa214d9
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rsync
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=fast incremental file transfer
+  TITLE:=Fast remote file copy program (like rcp)
+  DEPENDS:=+libpopt
   URL:=http://rsync.samba.org/
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               PREFIX="/usr" \
-       )
+define Package/rsync/description
+       sync is a program that allows files to be copied to
+       and from remote machines in much the same way as rcp.
+       It has many more options than rcp, and uses the rsync
+       remote-update protocol to greatly speed up file
+       transfers when the destination file already exists.
+
+       The rsync remote-update protocol allows rsync to
+       transfer just the differences between two sets of files
+       across the network link.
 endef
 
+CONFIGURE_ARGS += \
+       --with-included-popt=no \
+       --disable-debug \
+       --disable-ipv6 \
+       --disable-locale \
+       --disable-xattr-support \
+       --disable-acl-support \
+
 define Package/rsync/install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(1)" \
-               PREFIX="/usr" \
-               install-strip
-       rm -rf $(1)/usr/man
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rsync))