aMule: update to 2.3.1
[openwrt/svn-archive/archive.git] / net / rsync / Makefile
index a1170f6f2dd4a45333b9ba6484027ec4e1e883d4..f66c694f144b92409e4d90eb82c383148bc4d82b 100644 (file)
@@ -1,41 +1,81 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
-#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
-PKG_VERSION:=2.6.9
+PKG_VERSION:=3.1.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync
-PKG_MD5SUM:=996d8d8831dbca17910094e56dcb5942
+PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
+PKG_MD5SUM:=3be148772a33224771a8d4d2a028b132
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rsync
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=fast incremental file transfer
+  SUBMENU:=File Transfer
+  TITLE:=Fast remote file copy program (like rcp)
+  DEPENDS:=+libpopt +zlib
+  URL:=http://rsync.samba.org/
+endef
+
+define Package/rsyncd
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=File Transfer
+  TITLE:=Rsync daemon
+  DEPENDS:=+rsync
   URL:=http://rsync.samba.org/
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               PREFIX="/usr" \
-       )
+define Package/rsync/description
+ rsync is a program that allows files to be copied to and from remote machines
+ in much the same way as rcp. It has many more options than rcp, and uses the
+ rsync remote-update protocol to greatly speed up file transfers when the
+ destination file already exists.
+
+ The rsync remote-update protocol allows rsync to transfer just the differences
+ between two sets of files across the network link.
 endef
 
+CONFIGURE_ARGS += \
+       --with-included-popt=no \
+       --with-included-zlib=no \
+       --disable-debug \
+       --disable-locale \
+       --disable-xattr-support \
+       --disable-acl-support \
+
 define Package/rsync/install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(1)" \
-               PREFIX="/usr" \
-               install-strip
-       rm -rf $(1)/usr/man
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+endef
+
+define Package/rsyncd/description
+ rsyncd is a configuration file and initscript to utilize rsync as a daemon. It
+ uses the same binary as rsync.
+endef
+
+define Package/rsyncd/conffiles
+/etc/rsyncd.conf
+endef
+
+define Package/rsyncd/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/rsyncd.init $(1)/etc/init.d/rsyncd
 endef
 
 $(eval $(call BuildPackage,rsync))
+$(eval $(call BuildPackage,rsyncd))