[packages] quagga{,-unstable}: Merge quagga-unstable package with quagga package
[openwrt/svn-archive/archive.git] / net / rtorrent / Makefile
index fe44345adb1647babec53cc2be10e861b583a1a4..456bbe4b506e79b279532e66093063b85f8fe288 100644 (file)
@@ -1,25 +1,26 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
-
-PKG_REV:=1087
-PKG_VERSION:=0.8.4_r$(PKG_REV)
+PKG_REV:=1165
+PKG_VERSION:=0.8.6_r$(PKG_REV)
 PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=svn
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,7 +30,7 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c +libpthread
 endef
 
 define Package/rtorrent/description
@@ -39,8 +40,11 @@ define Package/rtorrent/description
  based clients in an ncurses client.
 endef
 
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
+
+TARGET_LDFLAGS += -lpthread
 
 CONFIGURE_ARGS+= \
        --enable-shared \
@@ -53,15 +57,9 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/rtorrent/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,rtorrent))