[package] update rtorrent to r1100 (#6111)
[openwrt/svn-archive/archive.git] / net / rtorrent / Makefile
index 2c411a5662243f36fbdd357c4e2250395d3493a8..e672b91ce4b53362e6cb311478893ea89afb9e99 100644 (file)
@@ -1,20 +1,23 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
-PKG_VERSION:=0.7.9
-PKG_RELEASE:=3
 
+PKG_REV:=1100
+PKG_VERSION:=0.8.5_r$(PKG_REV)
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
-PKG_MD5SUM:=136202fdd540a92aafbcee29f849d228
+PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
 
 PKG_FIXUP = libtool
 
@@ -26,7 +29,7 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c
 endef
 
 define Package/rtorrent/description
@@ -36,13 +39,20 @@ define Package/rtorrent/description
  based clients in an ncurses client.
 endef
 
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \
        --disable-debug \
+       --with-xmlrpc-c \
 
-CONFIGURE_VARS += \
-       LIBS="-lm" \
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); ./autogen.sh );
+       $(call Build/Configure/Default)
+endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \