[package] update rtorrent to r1100 (#6111)
[openwrt/svn-archive/archive.git] / net / rtorrent / Makefile
index 4a7714bed72c7a743111fd0b161616f8f96d9cd0..e672b91ce4b53362e6cb311478893ea89afb9e99 100644 (file)
@@ -1,17 +1,18 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
 
-PKG_REV:=1087
-PKG_VERSION:=0.8.4_r$(PKG_REV)
-PKG_RELEASE:=2
+PKG_REV:=1100
+PKG_VERSION:=0.8.5_r$(PKG_REV)
+PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -28,7 +29,7 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses +xmlrpc-c
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c
 endef
 
 define Package/rtorrent/description
@@ -38,14 +39,14 @@ define Package/rtorrent/description
  based clients in an ncurses client.
 endef
 
-TARGET_CPPFLAGS +=  \
-       -fno-strict-aliasing -fno-inline \
+ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
+TARGET_CPPFLAGS += -fno-strict-aliasing
+endif
 
 CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \
        --disable-debug \
-       --disable-tls \
        --with-xmlrpc-c \
 
 define Build/Configure