[8.09] [packages] merge r14667 (#5145)
[openwrt/svn-archive/archive.git] / net / samba / Makefile
index 3733145ad8e475a2af91bd226d5addf2abe0e2a0..a231b335b1c222e8e56259fce25fa1667248a29a 100644 (file)
@@ -10,15 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=2.0.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4.1
 PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
 
 PKG_SOURCE_URL:=ftp://se.samba.org/pub/samba/stable \
        ftp://ftp.easynet.be/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,13 +24,16 @@ define Package/samba
   CATEGORY:=Network
   SUBMENU:=samba - NetBIOS/SMB implementation
   TITLE:=samba - NetBIOS/SMB implementation
-  DESCRIPTION:=The Samba software suite is a collection of programs that implements the\\\
-  SMB protocol for unix systems, allowing you to serve files and printers to\\\
-  Windows, NT, OS/2 and DOS clients. This protocol is sometimes also referred\\\
-  to as the LanManager or Netbios protocol.
   URL:=http://www.samba.org/
 endef  
 
+define Package/samba/description
+The Samba software suite is a collection of programs that implements the
+       SMB protocol for unix systems, allowing you to serve files and printers to
+       Windows, NT, OS/2 and DOS clients. This protocol is sometimes also referred
+       to as the LanManager or Netbios protocol.
+endef
+
 define Package/samba-common
   $(call Package/samba)
   TITLE:=NetBIOS/SMB server and client shared files
@@ -88,7 +88,7 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DNDEBUG -DSHMEM_SIZE=524288 -Dfcntl=fcntl64" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-lgcc_s -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               LDFLAGS="$(LIBGCC_S) -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ac_cv_lib_cups_httpConnect=no \
                samba_cv_FTRUNCATE_NEEDS_ROOT=no \
                samba_cv_HAVE_BROKEN_FCNTL64_LOCKS=no \
@@ -181,11 +181,11 @@ define Package/samba-common/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbpasswd.shared $(1)/usr/bin/smbpasswd
        $(INSTALL_DIR) $(1)/usr/share/samba
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{437,850} $(1)/usr/share/samba/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850,ISO8859-1} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850,ISO8859-1,ISO8859-15} $(1)/usr/share/samba/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.852 $(1)/usr/share/samba/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{852,ISO8859-2} $(1)/usr/share/samba/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.866 $(1)/usr/share/samba/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{866,1251} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R,1251} $(1)/usr/share/samba/
 endef
 
 define Package/samba-server/install