packages/samba: remove dependency on libgcc
[openwrt/svn-archive/archive.git] / net / samba / Makefile
index a36270ae6c864899ded6bd4f79864d62fdb9ff20..d02c6801959d35ac138d945c3134749cff914a60 100644 (file)
@@ -1,31 +1,26 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=2.0.10
-PKG_RELEASE:=4
-PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
+PKG_RELEASE:=8
 
-PKG_SOURCE_URL:=ftp://se.samba.org/pub/samba/stable \
-       ftp://ftp.easynet.be/samba/stable
+PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/samba
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=samba - NetBIOS/SMB implementation
+  SUBMENU:=Filesystem
   TITLE:=samba - NetBIOS/SMB implementation
   URL:=http://www.samba.org/
 endef  
@@ -37,29 +32,33 @@ The Samba software suite is a collection of programs that implements the
        to as the LanManager or Netbios protocol.
 endef
 
-define Package/samba-common
+define Package/samba2-common
   $(call Package/samba)
+  MENU:=1
   TITLE:=NetBIOS/SMB server and client shared files
-  DEPENDS:=+libgcc
 endef
 
-define Package/samba-server
+define Package/samba2-server
   $(call Package/samba)
   TITLE:=NetBIOS/SMB file and print server
-  DEPENDS:=samba-common
+  DEPENDS:=samba2-common
 endef
 
-define Package/samba-client
+define Package/samba2-client
   $(call Package/samba)
   TITLE:=NetBIOS/SMB simple client
-  DEPENDS:=samba-common
+  DEPENDS:=samba2-common
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile   
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        (cd $(PKG_BUILD_DIR)/source ; rm -rf config.{cache,status} ; \
                ./configure \
+                       $(HOST_CONFIGURE_VARS) \
+                       $(HOST_CONFIGURE_ARGS) \
                        --program-prefix="" \
                        --program-suffix="" \
                        --prefix=/usr \
@@ -74,7 +73,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -90,8 +88,8 @@ define Build/Compile
        (cd $(PKG_BUILD_DIR)/source; rm -rf config.{cache,status}; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DNDEBUG -DSHMEM_SIZE=524288 -Dfcntl=fcntl64" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-lgcc_s -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS) $(LIBGCC_S)" \
                ac_cv_lib_cups_httpConnect=no \
                samba_cv_FTRUNCATE_NEEDS_ROOT=no \
                samba_cv_HAVE_BROKEN_FCNTL64_LOCKS=no \
@@ -145,7 +143,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -177,7 +174,7 @@ define Build/Compile
                install
 endef
 
-define Package/samba-common/install
+define Package/samba2-common/install
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf $(1)/etc/samba/smb.conf
        $(INSTALL_DIR) $(1)/usr/bin
@@ -187,11 +184,15 @@ define Package/samba-common/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850,ISO8859-1,ISO8859-15} $(1)/usr/share/samba/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.852 $(1)/usr/share/samba/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{852,ISO8859-2} $(1)/usr/share/samba/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.866 $(1)/usr/share/samba/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{866,1251} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R,1251} $(1)/usr/share/samba/
+endef
+
+define Package/samba2-common/conffiles
+/etc/samba/smb.conf
 endef
 
-define Package/samba-server/install
+define Package/samba2-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
        $(INSTALL_DIR) $(1)/usr/lib
@@ -201,11 +202,11 @@ define Package/samba-server/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbd.shared $(1)/usr/sbin/smbd
 endef
 
-define Package/samba-client/install
+define Package/samba2-client/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/smbclient $(1)/usr/bin/
 endef
 
-$(eval $(call BuildPackage,samba-common))
-$(eval $(call BuildPackage,samba-server))
-$(eval $(call BuildPackage,samba-client))
+$(eval $(call BuildPackage,samba2-common))
+$(eval $(call BuildPackage,samba2-server))
+$(eval $(call BuildPackage,samba2-client))