packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / samba / Makefile
index c47a8d41d93a31fbce8aeecc5622251fa83844b4..f9c2db37707981b564f29e7292ae6889ce0e0eea 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=2.0.10
-PKG_RELEASE:=6
-PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
+PKG_RELEASE:=7
 
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/samba
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=samba - NetBIOS/SMB implementation
+  SUBMENU:=Filesystem
   TITLE:=samba - NetBIOS/SMB implementation
   URL:=http://www.samba.org/
 endef  
@@ -32,29 +32,34 @@ The Samba software suite is a collection of programs that implements the
        to as the LanManager or Netbios protocol.
 endef
 
-define Package/samba-common
+define Package/samba2-common
   $(call Package/samba)
+  MENU:=1
   TITLE:=NetBIOS/SMB server and client shared files
   DEPENDS:=+libgcc
 endef
 
-define Package/samba-server
+define Package/samba2-server
   $(call Package/samba)
   TITLE:=NetBIOS/SMB file and print server
-  DEPENDS:=samba-common
+  DEPENDS:=samba2-common
 endef
 
-define Package/samba-client
+define Package/samba2-client
   $(call Package/samba)
   TITLE:=NetBIOS/SMB simple client
-  DEPENDS:=samba-common
+  DEPENDS:=samba2-common
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile   
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        (cd $(PKG_BUILD_DIR)/source ; rm -rf config.{cache,status} ; \
                ./configure \
+                       $(HOST_CONFIGURE_VARS) \
+                       $(HOST_CONFIGURE_ARGS) \
                        --program-prefix="" \
                        --program-suffix="" \
                        --prefix=/usr \
@@ -69,7 +74,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -140,7 +144,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -172,7 +175,7 @@ define Build/Compile
                install
 endef
 
-define Package/samba-common/install
+define Package/samba2-common/install
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf $(1)/etc/samba/smb.conf
        $(INSTALL_DIR) $(1)/usr/bin
@@ -186,7 +189,11 @@ define Package/samba-common/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R,1251} $(1)/usr/share/samba/
 endef
 
-define Package/samba-server/install
+define Package/samba2-common/conffiles
+/etc/samba/smb.conf
+endef
+
+define Package/samba2-server/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
        $(INSTALL_DIR) $(1)/usr/lib
@@ -196,11 +203,11 @@ define Package/samba-server/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbd.shared $(1)/usr/sbin/smbd
 endef
 
-define Package/samba-client/install
+define Package/samba2-client/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/smbclient $(1)/usr/bin/
 endef
 
-$(eval $(call BuildPackage,samba-common))
-$(eval $(call BuildPackage,samba-server))
-$(eval $(call BuildPackage,samba-client))
+$(eval $(call BuildPackage,samba2-common))
+$(eval $(call BuildPackage,samba2-server))
+$(eval $(call BuildPackage,samba2-client))