[packages] samba36: add source url for old versions
[openwrt/svn-archive/archive.git] / net / samba36 / Makefile
index 85b747e9563345355d54fa985533c64e52c0114d..6d59d5eba19471beef7da049a1bae594b51e550e 100644 (file)
@@ -11,8 +11,8 @@ PKG_NAME:=samba
 PKG_VERSION:=3.6.5
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL_SUBDIR:=/
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba$(PKG_SOURCE_URL_SUBDIR)
+PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
+       http://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
 
@@ -30,9 +30,17 @@ define Package/samba36-server
   URL:=http://www.samba.org/
 endef
 
+define Package/samba36-client
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Samba 3.6 SMB/CIFS client
+  URL:=http://www.samba.org/
+endef
+
 define Package/samba36-server/config
        config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
                int "Maximum level of compiled-in debug messages"
+               depends PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
 
 endef
@@ -119,5 +127,12 @@ define Package/samba36-server/install
        ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
 endef
 
+define Package/samba36-client/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_BIN)/smbclient $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_BIN)/nmblookup $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,samba36-client))
 $(eval $(call BuildPackage,samba36-server))