[packages] samba36: add source url for old versions
[openwrt/svn-archive/archive.git] / net / samba36 / Makefile
index edeb5fbba76b81775f15111ed29e2cea0a0bbb2e..6d59d5eba19471beef7da049a1bae594b51e550e 100644 (file)
@@ -1,21 +1,20 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.3
+PKG_VERSION:=3.6.5
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL_SUBDIR:=/
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba$(PKG_SOURCE_URL_SUBDIR)
+PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
+       http://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=98ac9db9f4b6ebfc3f013aa193ffb0d1
+PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,6 +30,21 @@ define Package/samba36-server
   URL:=http://www.samba.org/
 endef
 
+define Package/samba36-client
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Samba 3.6 SMB/CIFS client
+  URL:=http://www.samba.org/
+endef
+
+define Package/samba36-server/config
+       config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
+               int "Maximum level of compiled-in debug messages"
+               depends PACKAGE_samba36-server || PACKAGE_samba36-client
+               default -1
+
+endef
+
 define Package/samba36-server/description
  The Samba software suite is a collection of programs that implements the
  SMB protocol for UNIX systems, allowing you to serve files and printers to
@@ -38,7 +52,7 @@ define Package/samba36-server/description
  to as the LanManager or Netbios protocol.
 endef
 
-TARGET_CFLAGS += -DMAX_DEBUG_LEVEL=2 -D__location__=\\\"\\\" -ffunction-sections -fdata-sections
+TARGET_CFLAGS += -DMAX_DEBUG_LEVEL=$(CONFIG_PACKAGE_SAMBA_MAX_DEBUG_LEVEL) -D__location__=\\\"\\\" -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_VARS += \
@@ -56,7 +70,9 @@ CONFIGURE_VARS += \
        samba_cv_USE_SETREUID=yes \
        samba_cv_USE_SETRESUID=yes \
        samba_cv_have_setreuid=yes \
-       samba_cv_have_setresuid=yes
+       samba_cv_have_setresuid=yes \
+       ac_cv_header_zlib_h=no \
+       samba_cv_zlib_1_2_3=no
 
 CONFIGURE_ARGS += \
        --exec-prefix=/usr \
@@ -90,7 +106,7 @@ CONFIGURE_ARGS += \
        --without-libsmbclient \
        --without-libsmbsharemodes \
        --without-libaddns \
-       --with-shared-modules=
+       --with-shared-modules=pdb_tdbsam,pdb_wbc_sam,idmap_nss,nss_info_template,auth_winbind,auth_wbc,auth_domain
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
@@ -111,5 +127,12 @@ define Package/samba36-server/install
        ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
 endef
 
+define Package/samba36-client/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_BIN)/smbclient $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_BIN)/nmblookup $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,samba36-client))
 $(eval $(call BuildPackage,samba36-server))