[packages] dsl-qos-queue: use shared libipq (#8355)
[openwrt/svn-archive/archive.git] / net / scanlogd / Makefile
index dcdc4c39be50aa4c10204c4f32cd8d3a9f4f3e9d..1083ea8de24a241f880d33b20f6edd90265bb943 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -14,13 +13,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openwall.com/scanlogd/ \
-               ftp://ftp.wiretapped.net/pub/openwall/ \
-               http://distro.ibiblio.org/pub/linux/distributions/openwall/
+       ftp://ftp.wiretapped.net/pub/openwall/ \
+       http://distro.ibiblio.org/pub/linux/distributions/openwall/
 PKG_MD5SUM:=7b8187ea718ebe47f22805b921b909ab
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_INIT_PRIO:=60
 
@@ -31,14 +26,16 @@ define Package/scanlogd
   CATEGORY:=Network
   DEPENDS:=+libpcap +libnet0 +libnids
   TITLE:=Port scan detection tool
-  DESCRIPTION:=\
-       Scanlogd is a TCP port scan detection tool, originally designed \\\
-       to illustrate various attacks an IDS developer has to deal with.\\\
-       Thus, unlike some of the other port scan detection tools out there, \\\
-       scanlogd is designed to be totally safe to use.
   URL:=http://www.openwall.com/scanlogd
 endef
 
+define Package/scanlogd/description
+       Scanlogd is a TCP port scan detection tool, originally designed 
+       to illustrate various attacks an IDS developer has to deal with.
+       Thus, unlike some of the other port scan detection tools out there, 
+       scanlogd is designed to be totally safe to use.
+endef
+
 define Build/Configure 
        $(SED) "s,/var/empty,/tmp/.scanlogd," $(PKG_BUILD_DIR)/params.h
        $(SED) "s,#undef SCANLOGD_DEVICE,#define SCANLOGD_DEVICE \"all\"," $(PKG_BUILD_DIR)/params.h
@@ -49,18 +46,17 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                CC="$(TARGET_CC)" LD="$(TARGET_CC)" CFLAGS="-c $(TARGET_CFLAGS)" \
                LDFLAGS= \
-               PCAP_H="-I$(STAGING_DIR)/usr/include" \
-               NIDS_H="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/lib/libnet-1.0.x/include" \
-               NIDS_L="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libnet-1.0.x/lib -lnids -lnet -lpcap" \
+               PCAP_H="$(TARGET_CPPFLAGS)" \
+               NIDS_H="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/lib/libnet-1.0.x/include" \
+               NIDS_L="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/libnet-1.0.x/lib -lnids -lnet -lpcap" \
                libnids
 endef
 
 define Package/scanlogd/install        
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/scanlogd.init $(1)/etc/init.d/scanlogd
-       ln -sf scanlogd $(1)/etc/init.d/S$(PKG_INIT_PRIO)scanlogd
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/scanlogd.init $(1)/etc/init.d/scanlogd
 endef
 
 $(eval $(call BuildPackage,scanlogd))