[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / net / scdp / Makefile
index 4e3cbff18c156a024c9b8e471e1f65da299b5781..8c80131ce2e2d0240da81c4dbf3026f3864718cb 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/scdp
 PKG_MD5SUM:=7eafaf5a422e37d04715613993ed5d95
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,13 +24,15 @@ define Package/scdp
   CATEGORY:=Network
   DEPENDS:=+libnet0
   TITLE:=An utility to send CDP (Cisco Discovery Protocol) packets
-  DESCRIPTION:=\
-       This program sends CDP (Cisco Discovery Protocol) packets out on\\\
-       selected interfaces and tells the connected switch (cisco only)\\\
-       where the host is connected.
   URL:=http://sourceforge.net/projects/scdp
 endef
-                       
+
+define Package/scdp/description
+       This program sends CDP (Cisco Discovery Protocol) packets out on
+       selected interfaces and tells the connected switch (cisco only)
+       where the host is connected.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                , \
@@ -43,15 +42,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               all install
-endef
-
 define Package/scdp/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/scdp $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scdp $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,scdp))