[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / net / scdp / Makefile
index 6ce6387310f0e853d5ea1b1ca1b8ead9b23c3abc..8c80131ce2e2d0240da81c4dbf3026f3864718cb 100644 (file)
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/scdp
 PKG_MD5SUM:=7eafaf5a422e37d04715613993ed5d95
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/scdp
@@ -30,7 +32,7 @@ define Package/scdp/description
        selected interfaces and tells the connected switch (cisco only)
        where the host is connected.
 endef
-                       
+
 define Build/Configure
        $(call Build/Configure/Default, \
                , \
@@ -40,12 +42,6 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/scdp/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scdp $(1)/usr/bin/