[Packages] utils/lcd4linux: Fix compilation
[openwrt/svn-archive/archive.git] / net / scdp / Makefile
index edfce0cbc21b0b00794ea9c648b430fbe1bdf538..9ab08d53d08e34fbed6cd59e2a621a6f96a0569a 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/scdp
 PKG_MD5SUM:=7eafaf5a422e37d04715613993ed5d95
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,12 +26,14 @@ define Package/scdp
   CATEGORY:=Network
   DEPENDS:=+libnet0
   TITLE:=An utility to send CDP (Cisco Discovery Protocol) packets
-  DESCRIPTION:=\
-       This program sends CDP (Cisco Discovery Protocol) packets out on\\\
-       selected interfaces and tells the connected switch (cisco only)\\\
-       where the host is connected.
   URL:=http://sourceforge.net/projects/scdp
 endef
+
+define Package/scdp/description
+       This program sends CDP (Cisco Discovery Protocol) packets out on
+       selected interfaces and tells the connected switch (cisco only)
+       where the host is connected.
+endef
                        
 define Build/Configure
        $(call Build/Configure/Default, \
@@ -50,7 +51,7 @@ define Build/Compile
 endef
 
 define Package/scdp/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/scdp $(1)/usr/bin/
 endef