[packages] sane-backends: Update to v1.0.20 (closes #5662)
[openwrt/svn-archive/archive.git] / net / ser2net / Makefile
index c7e0013ff27c878ed398522e40e9314f517086e4..6027051ed5ac4d73ef863ddec0e1afb4bb67736f 100644 (file)
@@ -4,36 +4,33 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
        
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ser2net
-PKG_VERSION:=2.3
+PKG_VERSION:=2.5
 PKG_RELEASE:=1
  
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ser2net
-PKG_MD5SUM:=5f83a3e8aec18331cb61069dccdfba47
-PKG_CAT:=zcat
+PKG_MD5SUM:=c11f36ff2e4c523be7b282f2f6d03638
        
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ser2net
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Serial port TCP/IP redirector
-  DESCRIPTION:=\
-       This is ser2net, a program for allowing network connections to serial \\\
-       ports. See the man page for information about using the program. Note \\\
-       that ser2net supports RFC 2217 (remote control of serial port parameters), \\\
-       but you must have a complient client.
   URL:=http://sourceforge.net/projects/ser2net/
 endef
 
+define Package/ser2net/description
+       This is ser2net, a program for allowing network connections to serial 
+       ports. See the man page for information about using the program. Note 
+       that ser2net supports RFC 2217 (remote control of serial port parameters), 
+       but you must have a complient client.
+endef
+
 define Package/ser2net/conffiles
 /etc/ser2net.conf
 endef
@@ -47,9 +44,9 @@ define Build/Compile
 endef
  
 define Package/ser2net/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ser2net $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ser2net $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/ser2net.conf $(1)/etc/
 endef