[package] update openssh to 5.6p1
[openwrt/svn-archive/archive.git] / net / ser2net / Makefile
index c7e0013ff27c878ed398522e40e9314f517086e4..86d595559ef2d17fafe10a4efe0e06aa4c531abf 100644 (file)
@@ -1,24 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
-       
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ser2net
-PKG_VERSION:=2.3
-PKG_RELEASE:=1
+PKG_VERSION:=2.7
+PKG_RELEASE:=2
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ser2net
-PKG_MD5SUM:=5f83a3e8aec18331cb61069dccdfba47
-PKG_CAT:=zcat
-       
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=22977477789868923a5de09a85e847dd
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,31 +24,27 @@ define Package/ser2net
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Serial port TCP/IP redirector
-  DESCRIPTION:=\
-       This is ser2net, a program for allowing network connections to serial \\\
-       ports. See the man page for information about using the program. Note \\\
-       that ser2net supports RFC 2217 (remote control of serial port parameters), \\\
-       but you must have a complient client.
   URL:=http://sourceforge.net/projects/ser2net/
 endef
 
+define Package/ser2net/description
+  This is ser2net, a program for allowing network connections to serial ports.
+  See the man page for information about using the program. Note that ser2net
+  supports RFC 2217 (remote control of serial port parameters), but you must
+  have a complient client.
+endef
+
 define Package/ser2net/conffiles
 /etc/ser2net.conf
 endef
 
 # uses GNU configure
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
 define Package/ser2net/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ser2net $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc
-       $(CP) $(PKG_BUILD_DIR)/ser2net.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ser2net $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ser2net.conf $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,ser2net))