replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / shat / Makefile
index ce55ff9a1565c4009a1b281c960bc1b19d5eea09..679831e335c75b273b16ed2b80a9a36c94fb7040 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=shat
 PKG_VERSION:=0.9.7
 PKG_RELEASE:=1
-PKG_MD5SUM:= da06846f35838b14d1513523dad84d24
 
-PKG_SOURCE_URL:=http://world.maxina.de/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://world.maxina.de/src/
+PKG_MD5SUM:=da06846f35838b14d1513523dad84d24
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,21 +26,22 @@ define Package/shat
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Source Hardware Address Translation
-  DESCRIPTION:=A tool which allows hosts with arbitrary IP configuration\\\
+  DESCRIPTION:=\
+       A tool which allows hosts with arbitrary IP configuration\\\
        to connect to the internet over a SHAT gateway.\\\
   URL:=http://www.teddy-net.com/cvs/Maxina/128gw/service/arpcatch/shat/
 endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DVERSION=\\\"$(PKG_VERSION)\\\" -DDROP_NETBIOS"
 endef
 
 define Package/shat/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/shatd $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/src/shatc $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/shatd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/shatc $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,shat))