Update dmapd to 0.0.31
[openwrt/svn-archive/archive.git] / net / shat / Makefile
index ec7bdf4df8ad18da635b7b70790540da5e75a8ad..7412f53f148f054b369a295a5cf53fe7f5114b24 100644 (file)
@@ -4,21 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shat
 PKG_VERSION:=0.9.7
 PKG_RELEASE:=1
-PKG_MD5SUM:= da06846f35838b14d1513523dad84d24
 
-PKG_SOURCE_URL:=http://world.maxina.de/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/shat
+PKG_MD5SUM:=da06846f35838b14d1513523dad84d24
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,9 +21,13 @@ define Package/shat
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Source Hardware Address Translation
-  DESCRIPTION:=A tool which allows hosts with arbitrary IP configuration\\\
-       to connect to the internet over a SHAT gateway.\\\
-  URL:=http://www.teddy-net.com/cvs/Maxina/128gw/service/arpcatch/shat/
+  URL:=http://sourceforge.net/projects/shat/
+endef
+
+define Package/shat/description
+       A tool which allows hosts with arbitrary IP configuration
+       to connect to the internet over a SHAT gateway.
+
 endef
 
 define Build/Compile   
@@ -38,9 +37,9 @@ define Build/Compile
 endef
 
 define Package/shat/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/shatd $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/src/shatc $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/shatd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/shatc $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,shat))