upgrade shorewall - thanks to puchu
[openwrt/svn-archive/archive.git] / net / shorewall-common / Makefile
index 4640c250b6129de5323997428461c9360d5b5ed5..517b1d74ee48d2f9c377c7a06acd5a952b7cc680 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shorewall-common
-PKG_VERSION:=4.0.5
+PKG_VERSION:=4.2.4
 PKG_RELEASE:=1
-PKG_MD5SUM:=751fe1216c93a042f000c4bfabad1cde
 
-PKG_SOURCE_URL:=http://www1.shorewall.net/pub/shorewall/4.0/shorewall-$(PKG_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.shorewall.net/pub/shorewall/4.2/shorewall-$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=888130a12280f7bf9022009153ac63cd
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -44,7 +44,7 @@ define Package/shorewall-common/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_BIN) ./files/shorewall.init $(1)/etc/init.d/shorewall
        $(INSTALL_BIN) ./files/hostname $(1)/bin
-       $(CP) $(PKG_INSTALL_DIR)/sbin/shorewall $(1)/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/shorewall $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/etc/shorewall $(1)/etc
 endef