shorewall:
[openwrt/svn-archive/archive.git] / net / shorewall / Makefile
index b0b7f6fd1e7e5662f23c1a6b8ea118223579599a..46a81cdbfe7968eb61908966275f5c662ea93f1e 100644 (file)
@@ -1,36 +1,34 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shorewall
-PKG_VERSION:=3.4.2
-PKG_RELEASE:=1
-PKG_MD5SUM:=ca04cb57d2ff3995975e83155dd9944f
+PKG_VERSION:=3.4.6
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=http://www1.shorewall.net/pub/shorewall/3.4/shorewall-3.4.2/
+PKG_SOURCE_URL:=http://www1.shorewall.net/pub/$(PKG_NAME)/3.4/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=ec6a8bd3d6d0468b6302a7725851c39b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/shorewall
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+iptables
   TITLE:=Shorewall firewall
-  DESCRIPTION:=\
-       Shorewall Firewall is an iptables-based firewall for Linux.
   URL:=http://www.shorewall.net/
 endef
 
+define define Package/shorewall/description
+ Shorewall Firewall is an iptables-based firewall for Linux.
+endef
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
@@ -40,10 +38,10 @@ endef
 
 define Package/shorewall/install
        $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/$(PKG_NAME) $(1)/sbin
        $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
        $(INSTALL_DIR) $(1)/usr/share
-       $(INSTALL_BIN) ./files/shorewall.init $(1)/etc/init.d/shorewall
-       $(CP) $(PKG_INSTALL_DIR)/sbin/shorewall $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/etc/shorewall $(1)/etc
 endef