[packages] siproxd:
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index 63468f0052a4d17e244153590a62ec7830cf38fe..0f98d928a2a4967576aba5a2d43e905894bbd1a0 100644 (file)
@@ -9,52 +9,48 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
-PKG_VERSION:=0.5.12
-PKG_RELEASE:=1
-PKG_MD5SUM:=2fa02bd6f83070593bfc2d383ce614fa
+PKG_VERSION:=0.7.1
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=@SF/siproxd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/siproxd
+PKG_MD5SUM:=45e5a44803181e2bf3361d562060c904
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_FIXUP = libtool
+
 define Package/siproxd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libosip2
+  DEPENDS:=+libltdl +libosip2 +libpthread
   TITLE:=SIP (Session Initiation Protocol) proxy
-  DESCRIPTION:=A SIP (Session Initiation Protocol) proxy
   URL:=http://siproxd.sourceforge.net/
 endef
 
 define Package/siproxd/conffiles
-/etc/siproxd.conf
+/etc/config/siproxd
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-static --enable-shared)
-endef
-       
+# uses GNU configure
+
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               SUBDIRS="src scripts contrib" \
+               LIBLTDL="$(STAGING_DIR)/usr/lib/libltdl.la" \
                all install
 endef
 
 define Package/siproxd/install
-       install -d -m0755 $(1)/etc
-       $(CP) $(PKG_INSTALL_DIR)/etc/siproxd.conf.example $(1)/etc/siproxd.conf
-       $(CP) $(PKG_INSTALL_DIR)/etc/siproxd_passwd.cfg $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 files/siproxd.init $(1)/etc/init.d/siproxd
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/siproxd
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/siproxd/plugin_*.so* $(1)/usr/lib/siproxd/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/siproxd.config $(1)/etc/config/siproxd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/siproxd.init $(1)/etc/init.d/siproxd
 endef
 
 $(eval $(call BuildPackage,siproxd))