[packages] asterisk-1.6.x: add func_channel and func_blacklist
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index ab09eaea6fe895302edc9a7626b4e5a1224b3fa5..3b31403b79818574330dce162f92927568bdb382 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
 PKG_VERSION:=0.7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/siproxd
 PKG_MD5SUM:=45e5a44803181e2bf3361d562060c904
 
-include $(INCLUDE_DIR)/package.mk
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
-PKG_FIXUP = libtool
+include $(INCLUDE_DIR)/package.mk
 
 define Package/siproxd
   SECTION:=net
@@ -31,15 +32,12 @@ define Package/siproxd/conffiles
 /etc/config/siproxd
 endef
 
-# uses GNU configure
+CONFIGURE_ARGS+= \
+       --with-libosip-prefix="$(STAGING_DIR)/usr" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               SUBDIRS="src scripts contrib" \
-               LIBLTDL="$(STAGING_DIR)/usr/lib/libltdl.la" \
-               all install
-endef
+MAKE_FLAGS+= \
+       SUBDIRS="src scripts contrib" \
+       LIBLTDL="$(STAGING_DIR)/usr/lib/libltdl.la" \
 
 define Package/siproxd/install
        $(INSTALL_DIR) $(1)/usr/sbin