[packages] asterisk-1.6.x: add func_channel and func_blacklist
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index d4caa129a658f191109d2437d5578278329bfb60..3b31403b79818574330dce162f92927568bdb382 100644 (file)
@@ -1,54 +1,51 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
-PKG_VERSION:=0.5.13
-PKG_RELEASE:=1
+PKG_VERSION:=0.7.1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/siproxd
-PKG_MD5SUM:=91a572f80dd5a9af5a0f7f207fd34478
-PKG_CAT:=zcat
+PKG_MD5SUM:=45e5a44803181e2bf3361d562060c904
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/siproxd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libosip2
+  DEPENDS:=+libltdl +libosip2 +libpthread
   TITLE:=SIP (Session Initiation Protocol) proxy
   URL:=http://siproxd.sourceforge.net/
 endef
 
 define Package/siproxd/conffiles
-/etc/siproxd.conf
+/etc/config/siproxd
 endef
 
-# uses GNU configure
-       
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               SUBDIRS="src scripts contrib" \
-               all install
-endef
+CONFIGURE_ARGS+= \
+       --with-libosip-prefix="$(STAGING_DIR)/usr" \
+
+MAKE_FLAGS+= \
+       SUBDIRS="src scripts contrib" \
+       LIBLTDL="$(STAGING_DIR)/usr/lib/libltdl.la" \
 
 define Package/siproxd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/siproxd.conf.example $(1)/etc/siproxd.conf
-       install -m0600 $(PKG_BUILD_DIR)/doc/siproxd_passwd.cfg $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/lib/siproxd
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/siproxd/plugin_*.so* $(1)/usr/lib/siproxd/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/siproxd.config $(1)/etc/config/siproxd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/siproxd.init $(1)/etc/init.d/siproxd
 endef