[package] siproxd: update to 0.8.1
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index d717ff71a8620f148fb99c7af273677daff0c8bc..adaa1651910b17cf99837c9ad650ca21453f422c 100644 (file)
@@ -1,61 +1,60 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
-PKG_VERSION:=0.5.13
+PKG_VERSION:=0.8.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=91a572f80dd5a9af5a0f7f207fd34478
-
-PKG_SOURCE_URL:=@SF/siproxd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/siproxd
+PKG_MD5SUM:=1a6f9d13aeb2d650375c9a346ac6cbaf
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=libosip2
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/siproxd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libosip2
+  SUBMENU:=Telephony
+  DEPENDS:=+libltdl +libpthread
   TITLE:=SIP (Session Initiation Protocol) proxy
-  DESCRIPTION:=A SIP (Session Initiation Protocol) proxy
   URL:=http://siproxd.sourceforge.net/
 endef
 
-define Package/siproxd/conffiles
-/etc/siproxd.conf
+define Package/siproxd/description
+       Siproxd is a proxy/masquerading daemon for the SIP protocol.
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-static --enable-shared)
-endef
-       
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               SUBDIRS="src scripts contrib" \
-               all install
+define Package/siproxd/conffiles
+/etc/config/siproxd
 endef
 
+CONFIGURE_ARGS+= \
+       --enable-static-libosip2 \
+       --with-libosip-prefix="$(STAGING_DIR)/usr" \
+       --disable-doc \
+       --disable-shared
+
+MAKE_FLAGS+= \
+       SUBDIRS="src scripts contrib" \
+       LIBLTDL="$(STAGING_DIR)/usr/lib/libltdl.la" \
+
 define Package/siproxd/install
-       install -d -m0755 $(1)/etc
-       $(CP) $(PKG_BUILD_DIR)/doc/siproxd.conf.example $(1)/etc/siproxd.conf
-       $(CP) $(PKG_BUILD_DIR)/doc/siproxd_passwd.cfg $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 files/siproxd.init $(1)/etc/init.d/siproxd
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/siproxd.config $(1)/etc/config/siproxd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/siproxd.init $(1)/etc/init.d/siproxd
 endef
 
 $(eval $(call BuildPackage,siproxd))