use Build/Configure/Default macro, don't check for libusb - it doesn't seem to be...
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index 63468f0052a4d17e244153590a62ec7830cf38fe..d717ff71a8620f148fb99c7af273677daff0c8bc 100644 (file)
@@ -9,9 +9,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
-PKG_VERSION:=0.5.12
+PKG_VERSION:=0.5.13
 PKG_RELEASE:=1
-PKG_MD5SUM:=2fa02bd6f83070593bfc2d383ce614fa
+PKG_MD5SUM:=91a572f80dd5a9af5a0f7f207fd34478
 
 PKG_SOURCE_URL:=@SF/siproxd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -44,13 +44,14 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               SUBDIRS="src scripts contrib" \
                all install
 endef
 
 define Package/siproxd/install
        install -d -m0755 $(1)/etc
-       $(CP) $(PKG_INSTALL_DIR)/etc/siproxd.conf.example $(1)/etc/siproxd.conf
-       $(CP) $(PKG_INSTALL_DIR)/etc/siproxd_passwd.cfg $(1)/etc/
+       $(CP) $(PKG_BUILD_DIR)/doc/siproxd.conf.example $(1)/etc/siproxd.conf
+       $(CP) $(PKG_BUILD_DIR)/doc/siproxd_passwd.cfg $(1)/etc/
        install -d -m0755 $(1)/etc/init.d
        install -m0755 files/siproxd.init $(1)/etc/init.d/siproxd
        install -d -m0755 $(1)/usr/sbin