update libosip2 and siproxd (patch by Alina Friedrichsen)
[openwrt/svn-archive/archive.git] / net / siproxd / Makefile
index de78300fa28111411c460de0382501fc6f9b0274..fdcc9a20fe61bc01c7f9bda282fec11bd991aedf 100644 (file)
@@ -4,17 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id: Makefile 9695 2007-12-09 18:59:01Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
-PKG_VERSION:=0.5.13
+PKG_VERSION:=0.7.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/siproxd
-PKG_MD5SUM:=91a572f80dd5a9af5a0f7f207fd34478
+PKG_MD5SUM:=6c978eef0d00160e50073e2e2fd8c23d
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -29,12 +29,12 @@ define Package/siproxd
   URL:=http://siproxd.sourceforge.net/
 endef
 
-define Package/siproxd/conffiles
-/etc/siproxd.conf
-endef
+#define Package/siproxd/conffiles
+#/etc/siproxd.conf
+#endef
 
 # uses GNU configure
-       
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -45,9 +45,11 @@ endef
 define Package/siproxd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/siproxd.conf.example $(1)/etc/siproxd.conf
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/siproxd_passwd.cfg $(1)/etc/
+#      $(INSTALL_DIR) $(1)/etc
+#      $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/siproxd.conf.example $(1)/etc/siproxd.conf
+#      $(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/siproxd_passwd.cfg $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/siproxd.config $(1)/etc/config/siproxd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/siproxd.init $(1)/etc/init.d/siproxd
 endef