unfs3 is not parallel build safe
[openwrt/svn-archive/archive.git] / net / slurm / Makefile
index 3d6a55409921250537515cc210ae73ed3f298e89..53096f0f05c2f27a3f472a925eb8e6f70434dda8 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,12 +12,10 @@ PKG_VERSION:=0.3.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
+PKG_SOURCE_URL:=http://www.wormulon.net/slurm/
 PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,17 +24,26 @@ define Package/slurm
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A realtime network interface monitor
-  DESCRIPTION:=\
-       A realtime network interface monitor with the following features: \\\
-       - realtime traffic statistics divided into incoming and outgoing ;\\\
-       - optional combined view ;\\\
-       - can monitor any kind of network interface ;\\\
-       - shows detailed statistics about the interface ;\\\
+  URL:=http://www.wormulon.net/slurm/
+endef
+
+define Package/slurm/description
+       A realtime network interface monitor with the following features: 
+       - realtime traffic statistics divided into incoming and outgoing ;
+       - optional combined view ;
+       - can monitor any kind of network interface ;
+       - shows detailed statistics about the interface ;
        - it's themeable.
-  URL:=http://www.wormulon.net/projects/slurm
 endef
 
-define Build/Configure 
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               config.h.in \
+               configure \
+       );
        $(call Build/Configure/Default, \
                , \
                LIBS="-lncurses" \
@@ -45,15 +51,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/slurm/install   
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
+define Package/slurm/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,slurm))