Add nufw
[openwrt/svn-archive/archive.git] / net / slurm / Makefile
index 1983104c71d2d42d8b1f8672f3a2db46fbcb0e97..6ba417aaf826dca14bd239175be3b0342a121203 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
 PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -27,16 +26,18 @@ define Package/slurm
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A realtime network interface monitor
-  DESCRIPTION:=\
-       A realtime network interface monitor with the following features: \\\
-       - realtime traffic statistics divided into incoming and outgoing ;\\\
-       - optional combined view ;\\\
-       - can monitor any kind of network interface ;\\\
-       - shows detailed statistics about the interface ;\\\
-       - it's themeable.
   URL:=http://www.wormulon.net/projects/slurm
 endef
 
+define Package/slurm/description
+       A realtime network interface monitor with the following features: 
+       - realtime traffic statistics divided into incoming and outgoing ;
+       - optional combined view ;
+       - can monitor any kind of network interface ;
+       - shows detailed statistics about the interface ;
+       - it's themeable.
+endef
+
 define Build/Configure 
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
@@ -60,7 +61,7 @@ endef
 
 define Package/slurm/install   
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,slurm))