Add nufw
[openwrt/svn-archive/archive.git] / net / slurm / Makefile
index 8a3b40bc946c3acb9c905312b8e344978d848f0c..6ba417aaf826dca14bd239175be3b0342a121203 100644 (file)
@@ -11,11 +11,11 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=slurm
 PKG_VERSION:=0.3.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
 
-PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
+PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -26,63 +26,42 @@ define Package/slurm
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A realtime network interface monitor
-  DESCRIPTION:=A realtime network interface monitor with the following features:\\\
-               * realtime traffic statistics divided into incoming and outgoing\\\
-               * optional combined view\\\
-               * can monitor any kind of network interface\\\
-               * shows detailed statistics about the interface.\\\
-               * it's themeable\\\
   URL:=http://www.wormulon.net/projects/slurm
 endef
 
+define Package/slurm/description
+       A realtime network interface monitor with the following features: 
+       - realtime traffic statistics divided into incoming and outgoing ;
+       - optional combined view ;
+       - can monitor any kind of network interface ;
+       - shows detailed statistics about the interface ;
+       - it's themeable.
+endef
+
 define Build/Configure 
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               touch configure.in; \
-               touch aclocal.m4; \
-               touch Makefile.in; \
-               touch config.h.in; \
-               touch configure; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               config.h.in \
+               configure \
+       );
+       $(call Build/Configure/Default, \
+               , \
                LIBS="-lncurses" \
-               ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_lib_ncurses_use_default_colors=yes \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-       );
+       )
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/slurm/install   
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/slurm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,slurm))