aircrack-ng: Enable parallel build
[openwrt/svn-archive/archive.git] / net / socat / Makefile
index 552077fe7f1dc768a6afba6990bf910c7411c927..43a595bd42a33fd35850dba90199ac55b0d4a375 100644 (file)
@@ -4,58 +4,52 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=socat
-PKG_VERSION:=1.4.3.0
+PKG_VERSION:=1.6.0.1
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
-PKG_MD5SUM:=ce574e75c2fda4456e8efd4efb86ec5e
-PKG_CAT:=bzcat
+PKG_MD5SUM:=6a0dd33cde2a18eb382433aca8f76ce2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/socat
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +libpthread
+  DEPENDS:=+libpthread
   TITLE:=A multipurpose relay (SOcket CAT)
-  DESCRIPTION:=\
-       SoCat (for SOcket CAT) establishes two bidirectional byte streams and \\\
-       transfers data between them.\\\
-       Data channels may be files, pipes, devices (terminal or modem, etc.), or \\\
-       sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking, \\\
-       logging and tracing, different modes for interprocess communication and \\\
-       many more options.
   URL:=http://www.dest-unreach.org/socat/
 endef
 
+define Package/socat/description
+       SoCat (for SOcket CAT) establishes two bidirectional byte streams and
+       transfers data between them.
+       Data channels may be files, pipes, devices (terminal or modem, etc.), or
+       sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,
+       logging and tracing, different modes for interprocess communication and
+       many more options.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --disable-libwrap \
                --disable-readline \
-               --disable-termios \
+               --disable-openssl \
+               --enable-termios \
                , \
                sc_cv_termios_ispeed="no" \
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/socat/install   
+define Package/socat/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/socat $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/socat $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,socat))