[packages] Require* calls must now be placed before BuildPackage calls
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index 7384d1266156449b2cfe44b5d133db7270f8651d..29e3fd54e587ab2b9ecd123a484b11c72224b8f8 100644 (file)
@@ -1,45 +1,53 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
-#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.5.STABLE13
+PKG_VERSION:=2.6.STABLE14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.5/
-PKG_MD5SUM:=3e64468e123be1246d17486dab6bee87
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
+PKG_MD5SUM:=eadb138d48320df8b99349121159c6bf
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/squid/Default
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://www.squid-cache.org
+  URL:=http://www.squid-cache.org/
 endef
 
 define Package/squid
   $(call Package/squid/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpthread
+  DEPENDS:=+libopenssl +libpthread @LINUX_2_6
   TITLE:=full-featured Web proxy cache
-  DESCRIPTION:=\
-       Squid is a high-performance proxy caching server for web clients, \\\
-       supporting FTP, gopher, and HTTP data objects. Unlike traditional \\\
-       caching software, Squid handles all requests in a single, \\\
+endef
+
+define Package/squid/description
+       Squid is a high-performance proxy caching server for web clients, 
+       supporting FTP, gopher, and HTTP data objects. Unlike traditional 
+       caching software, Squid handles all requests in a single, 
        non-blocking, I/O-driven process.
 endef
 
+define Package/squid/conffiles
+/etc/squid/mime.conf
+/etc/squid/squid.conf
+endef
+
+define Package/squid-mod-cachemgr
+  $(call Package/squid/Default)
+  DEPENDS:=squid
+  TITLE:=Web based proxy manager and reporting tool
+endef
+
 define Package/squid-mod-basic-auth-getpwnam
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -58,12 +66,6 @@ define Package/squid-mod-basic-auth-smb
   TITLE:=Samba basic authentication helper
 endef
 
-define Package/squid-mod-basic-auth-winbind
-  $(call Package/squid/Default)
-  DEPENDS:=squid
-  TITLE:=Winbind basic authentication helper
-endef
-
 define Package/squid-mod-digest-auth-password
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -82,12 +84,6 @@ define Package/squid-mod-external-acl-unix-group
   TITLE:=Unix group external ACL helper
 endef
 
-define Package/squid-mod-external-acl-winbind-group
-  $(call Package/squid/Default)
-  DEPENDS:=squid
-  TITLE:=Winbind group external ACL helper
-endef
-
 define Package/squid-mod-ntlm-auth-fakeauth
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -100,104 +96,91 @@ define Package/squid-mod-ntlm-auth-smb-auth
   TITLE:=Samba NTLM authentication helper
 endef
 
-define Package/squid-mod-ntlm-auth-winbind-auth
-  $(call Package/squid/Default)
-  DEPENDS:=squid
-  TITLE:=Winbind NTLM authentication helper
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --datadir=/usr/share/squid \
-               --libexecdir=/usr/lib/squid \
-               --sysconfdir=/etc/squid \
-               --enable-shared \
-               --enable-static \
-               --with-gnu-ld \
-               --enable-x-accelerator-vary \
-               --with-pthreads \
-               --with-dl \
-               --enable-icmp \
-               --enable-kill-parent-hack \
-               --enable-arp-acl \
-               --enable-ssl \
-               --enable-htcp \
-               --enable-err-languages=English \
-               --enable-default-err-language=English \
-               --enable-linux-netfilter \
-               --enable-icmp \
-               --enable-external-acl-helpers="" \
-               --enable-underscores \
-               --enable-cache-digests \
-               --enable-referer-log \
-               --enable-delay-pools \
-               --enable-useragent-log \
-               --with-openssl=$(STAGING_DIR)/usr \
-               --enable-auth="basic digest ntlm" \
-               --enable-basic-auth-helpers="getpwnam NCSA SMB winbind" \
-               --enable-ntlm-auth-helpers="fakeauth SMB winbind" \
-               --enable-digest-auth-helpers="password" \
-               --enable-external-acl-helpers="ip_user unix_group winbind_group" \
-               , \
-               ac_cv_sizeof_void_p=4 \
-               ac_cv_sizeof_short=2 \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4 \
-               ac_cv_sizeof_long_long=8 \
-               ac_cv_sizeof___int64=0 \
-               ac_cv_sizeof_int16_t=2 \
-               ac_cv_sizeof_uint16_t=2 \
-               ac_cv_sizeof_u_int16_t=2 \
-               ac_cv_sizeof_int32_t=4 \
-               ac_cv_sizeof_uint32_t=4 \
-               ac_cv_sizeof_u_int32_t=4 \
-               ac_cv_sizeof_int64_t=8 \
-               ac_cv_sizeof_uint64_t=8 \
-               ac_cv_sizeof_u_int64_t=8 \
-               ac_cv_func_setresuid=no \
-               ac_cv_func_va_copy=no \
-               ac_cv_func___va_copy=no \
-        )
-endef
-       
-define Build/Compile   
+CONFIGURE_ARGS += \
+       --datadir=/usr/share/squid \
+       --libexecdir=/usr/lib/squid \
+       --sysconfdir=/etc/squid \
+       --enable-shared \
+       --enable-static \
+       --enable-x-accelerator-vary \
+       --with-pthreads \
+       --with-dl \
+       --enable-icmp \
+       --enable-kill-parent-hack \
+       --enable-arp-acl \
+       --enable-ssl \
+       --enable-htcp \
+       --enable-err-languages=English \
+       --enable-default-err-language=English \
+       --enable-linux-netfilter \
+       --enable-icmp \
+       --enable-external-acl-helpers="" \
+       --enable-underscores \
+       --enable-cache-digests \
+       --enable-referer-log \
+       --enable-delay-pools \
+       --enable-useragent-log \
+       --with-openssl=$(STAGING_DIR)/usr \
+       --enable-auth="basic digest ntlm" \
+       --enable-basic-auth-helpers="getpwnam NCSA SMB" \
+       --enable-ntlm-auth-helpers="fakeauth SMB" \
+       --enable-digest-auth-helpers="password" \
+       --enable-external-acl-helpers="ip_user unix_group" \
+       --enable-epoll \
+       --with-maxfd=4096
+
+CONFIGURE_VARS += \
+       ac_cv_header_linux_netfilter_ipv4_h=yes \
+
+define Build/Compile
        # pass INCLUDES to compile host sources against our OpenSSL, not the host one
        $(MAKE) -C $(PKG_BUILD_DIR)/lib \
-               INCLUDES="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               INCLUDES="$(TARGET_CPPFLAGS)" \
                all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/squid/install   
-       install -d -m0755 $(1)/etc/squid
-       $(CP) $(PKG_INSTALL_DIR)/etc/squid/mime.conf $(1)/etc/squid/
-       $(CP) $(PKG_INSTALL_DIR)/etc/squid/squid.conf $(1)/etc/squid/
-       install -d -m0755 $(1)/usr/share/squid
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/squid/* $(1)/usr/share/squid/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+               install
 endef
 
 define BuildPlugin
   define Package/$(1)/install
-       install -d -m0755 $$(1)/usr/lib/squid
+       $(INSTALL_DIR) $$(1)/usr/lib/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
   endef
 
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
+define Package/squid/install
+       $(INSTALL_DIR) $(1)/etc/squid
+       $(CP) $(PKG_INSTALL_DIR)/etc/squid/mime.conf $(1)/etc/squid/
+       $(CP) $(PKG_INSTALL_DIR)/etc/squid/squid.conf $(1)/etc/squid/
+       $(INSTALL_DIR) $(1)/usr/share/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/squid/* $(1)/usr/share/squid/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
+endef
+
+define Package/squid-mod-cachemgr/install
+       $(INSTALL_DIR) $(1)/www/cgi-bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/cachemgr.cgi $(1)/www/cgi-bin/
+endef
+
+$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
+       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,squid))
+$(eval $(call BuildPackage,squid-mod-cachemgr))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-getpwnam,getpwname_auth))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-ncsa,ncsa_auth))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-smb,smb_auth))
-$(eval $(call BuildPlugin,squid-mod-basic-auth-winbind,wb_auth))
 $(eval $(call BuildPlugin,squid-mod-digest-auth-password,digest_pw_auth))
 $(eval $(call BuildPlugin,squid-mod-external-acl-ip-user,ip_user_check))
 $(eval $(call BuildPlugin,squid-mod-external-acl-unix-group,squid_unix_group))
-$(eval $(call BuildPlugin,squid-mod-external-acl-winbind-group,wb_group))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth))
-$(eval $(call BuildPlugin,squid-mod-ntlm-auth-winbind-auth,wb_ntlmauth))
+