[packages] python: add dependency on python-core to subpackages
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index 6e68545269b24a079279c4f6e552640c7af6b022..a075e7577d3d64f4c32c8a06c272eb6166560c0f 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
 PKG_MD5SUM:=eadb138d48320df8b99349121159c6bf
-PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -31,12 +30,14 @@ endef
 define Package/squid
   $(call Package/squid/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpthread
+  DEPENDS:=+libopenssl +libpthread @LINUX_2_6
   TITLE:=full-featured Web proxy cache
-  DESCRIPTION:=\
-       Squid is a high-performance proxy caching server for web clients, \\\
-       supporting FTP, gopher, and HTTP data objects. Unlike traditional \\\
-       caching software, Squid handles all requests in a single, \\\
+endef
+
+define Package/squid/description
+       Squid is a high-performance proxy caching server for web clients, 
+       supporting FTP, gopher, and HTTP data objects. Unlike traditional 
+       caching software, Squid handles all requests in a single, 
        non-blocking, I/O-driven process.
 endef
 
@@ -161,7 +162,7 @@ define Package/squid/install
        $(INSTALL_DIR) $(1)/usr/share/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/share/squid/* $(1)/usr/share/squid/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
 endef
@@ -181,3 +182,8 @@ $(eval $(call BuildPlugin,squid-mod-external-acl-ip-user,ip_user_check))
 $(eval $(call BuildPlugin,squid-mod-external-acl-unix-group,squid_unix_group))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth))
+
+$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
+       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))