packages: Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index 4473b1b0c67dd8360f083a69cb3eb12b56362606..b0b4d252130439cbef0b9e3fbec88a1bfd420dca 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.6.STABLE12
+PKG_VERSION:=2.6.STABLE14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
-PKG_MD5SUM:=a830ccc95cb39cdfa5e5b773add0bb0d
-PKG_CAT:=bzcat
+PKG_MD5SUM:=eadb138d48320df8b99349121159c6bf
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -33,10 +32,12 @@ define Package/squid
   MENU:=1
   DEPENDS:=+libopenssl +libpthread
   TITLE:=full-featured Web proxy cache
-  DESCRIPTION:=\
-       Squid is a high-performance proxy caching server for web clients, \\\
-       supporting FTP, gopher, and HTTP data objects. Unlike traditional \\\
-       caching software, Squid handles all requests in a single, \\\
+endef
+
+define Package/squid/description
+       Squid is a high-performance proxy caching server for web clients, 
+       supporting FTP, gopher, and HTTP data objects. Unlike traditional 
+       caching software, Squid handles all requests in a single, 
        non-blocking, I/O-driven process.
 endef
 
@@ -161,7 +162,7 @@ define Package/squid/install
        $(INSTALL_DIR) $(1)/usr/share/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/share/squid/* $(1)/usr/share/squid/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
 endef
@@ -181,3 +182,8 @@ $(eval $(call BuildPlugin,squid-mod-external-acl-ip-user,ip_user_check))
 $(eval $(call BuildPlugin,squid-mod-external-acl-unix-group,squid_unix_group))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth))
+
+$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
+       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))