[package] update squid to 2.6STABLE23
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index bd54e6e857a9df70c5c6c262bd0339c04d929b8f..ba9ed67f0f377bc80fb69e2a4e55edb33e88b1d0 100644 (file)
@@ -1,20 +1,19 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.6.STABLE14
+PKG_VERSION:=2.6.STABLE23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
-PKG_MD5SUM:=eadb138d48320df8b99349121159c6bf
+PKG_MD5SUM:=71aa24580f8a538ad84037bf2ac6f078
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -128,15 +127,16 @@ CONFIGURE_ARGS += \
        --enable-digest-auth-helpers="password" \
        --enable-external-acl-helpers="ip_user unix_group" \
        --enable-epoll \
-       --with-maxfd=4096 \
-       
+       --with-maxfd=4096
+
 CONFIGURE_VARS += \
        ac_cv_header_linux_netfilter_ipv4_h=yes \
+       ac_cv_epoll_works=yes \
 
 define Build/Compile
        # pass INCLUDES to compile host sources against our OpenSSL, not the host one
        $(MAKE) -C $(PKG_BUILD_DIR)/lib \
-               INCLUDES="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               INCLUDES="$(TARGET_CPPFLAGS)" \
                all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -169,6 +169,11 @@ define Package/squid-mod-cachemgr/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/cachemgr.cgi $(1)/www/cgi-bin/
 endef
 
+$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
+       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,squid))
 $(eval $(call BuildPackage,squid-mod-cachemgr))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-getpwnam,getpwname_auth))
@@ -180,7 +185,3 @@ $(eval $(call BuildPlugin,squid-mod-external-acl-unix-group,squid_unix_group))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth))
 
-$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
-       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
-       depending of your package manager) package be installed on the host-system. \
-))