update squid to 2.5.STABLE14 (as suggested by epac on irc), set squid/conffiles,...
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index 6830220314d1a90f373299cbf7cf5a3d88f3046a..d2a8247f1d2dabdbce37da1491151569655fb6da 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.5.STABLE13
+PKG_VERSION:=2.5.STABLE14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.5/
-PKG_MD5SUM:=3e64468e123be1246d17486dab6bee87
+PKG_MD5SUM:=f413e0b887a5f9b2a75350243ed5564c
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/squid/Default
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://www.squid-cache.org
+  URL:=http://www.squid-cache.org/
 endef
 
 define Package/squid
@@ -40,6 +40,11 @@ define Package/squid
        non-blocking, I/O-driven process.
 endef
 
+define Package/squid/conffiles
+/etc/squid/mime.conf
+/etc/squid/squid.conf
+endef
+
 define Package/squid-mod-cachemgr
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -119,7 +124,6 @@ define Build/Configure
                --sysconfdir=/etc/squid \
                --enable-shared \
                --enable-static \
-               --with-gnu-ld \
                --enable-x-accelerator-vary \
                --with-pthreads \
                --with-dl \
@@ -157,6 +161,15 @@ define Build/Compile
                all install
 endef
 
+define BuildPlugin
+  define Package/$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
+  endef
+
+  $$(eval $$(call BuildPackage,$(1)))
+endef
+
 define Package/squid/install   
        $(INSTALL_DIR) $(1)/etc/squid
        $(CP) $(PKG_INSTALL_DIR)/etc/squid/mime.conf $(1)/etc/squid/
@@ -174,15 +187,6 @@ define Package/squid-mod-cachemgr/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/cachemgr.cgi $(1)/www/cgi-bin/
 endef
 
-define BuildPlugin
-  define Package/$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/lib/squid
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
-  endef
-
-  $$(eval $$(call BuildPackage,$(1)))
-endef
-
 $(eval $(call BuildPackage,squid))
 $(eval $(call BuildPackage,squid-mod-cachemgr))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-getpwnam,getpwname_auth))