patch file cleanup... ick.. kaloz you owe me some love
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index 7384d1266156449b2cfe44b5d133db7270f8651d..d2a8247f1d2dabdbce37da1491151569655fb6da 100644 (file)
@@ -5,16 +5,16 @@
 # See /LICENSE for more information.
 #
 # $Id$
-#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.5.STABLE13
+PKG_VERSION:=2.5.STABLE14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.5/
-PKG_MD5SUM:=3e64468e123be1246d17486dab6bee87
+PKG_MD5SUM:=f413e0b887a5f9b2a75350243ed5564c
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/squid/Default
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://www.squid-cache.org
+  URL:=http://www.squid-cache.org/
 endef
 
 define Package/squid
@@ -40,6 +40,17 @@ define Package/squid
        non-blocking, I/O-driven process.
 endef
 
+define Package/squid/conffiles
+/etc/squid/mime.conf
+/etc/squid/squid.conf
+endef
+
+define Package/squid-mod-cachemgr
+  $(call Package/squid/Default)
+  DEPENDS:=squid
+  TITLE:=Web based proxy manager and reporting tool
+endef
+
 define Package/squid-mod-basic-auth-getpwnam
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -113,7 +124,6 @@ define Build/Configure
                --sysconfdir=/etc/squid \
                --enable-shared \
                --enable-static \
-               --with-gnu-ld \
                --enable-x-accelerator-vary \
                --with-pthreads \
                --with-dl \
@@ -138,26 +148,7 @@ define Build/Configure
                --enable-ntlm-auth-helpers="fakeauth SMB winbind" \
                --enable-digest-auth-helpers="password" \
                --enable-external-acl-helpers="ip_user unix_group winbind_group" \
-               , \
-               ac_cv_sizeof_void_p=4 \
-               ac_cv_sizeof_short=2 \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4 \
-               ac_cv_sizeof_long_long=8 \
-               ac_cv_sizeof___int64=0 \
-               ac_cv_sizeof_int16_t=2 \
-               ac_cv_sizeof_uint16_t=2 \
-               ac_cv_sizeof_u_int16_t=2 \
-               ac_cv_sizeof_int32_t=4 \
-               ac_cv_sizeof_uint32_t=4 \
-               ac_cv_sizeof_u_int32_t=4 \
-               ac_cv_sizeof_int64_t=8 \
-               ac_cv_sizeof_uint64_t=8 \
-               ac_cv_sizeof_u_int64_t=8 \
-               ac_cv_func_setresuid=no \
-               ac_cv_func_va_copy=no \
-               ac_cv_func___va_copy=no \
-        )
+       )
 endef
        
 define Build/Compile   
@@ -170,26 +161,34 @@ define Build/Compile
                all install
 endef
 
+define BuildPlugin
+  define Package/$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
+  endef
+
+  $$(eval $$(call BuildPackage,$(1)))
+endef
+
 define Package/squid/install   
-       install -d -m0755 $(1)/etc/squid
+       $(INSTALL_DIR) $(1)/etc/squid
        $(CP) $(PKG_INSTALL_DIR)/etc/squid/mime.conf $(1)/etc/squid/
        $(CP) $(PKG_INSTALL_DIR)/etc/squid/squid.conf $(1)/etc/squid/
-       install -d -m0755 $(1)/usr/share/squid
+       $(INSTALL_DIR) $(1)/usr/share/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/share/squid/* $(1)/usr/share/squid/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
 endef
 
-define BuildPlugin
-  define Package/$(1)/install
-       install -d -m0755 $$(1)/usr/lib/squid
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
-  endef
-
-  $$(eval $$(call BuildPackage,$(1)))
+define Package/squid-mod-cachemgr/install
+       $(INSTALL_DIR) $(1)/www/cgi-bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/cachemgr.cgi $(1)/www/cgi-bin/
 endef
 
 $(eval $(call BuildPackage,squid))
+$(eval $(call BuildPackage,squid-mod-cachemgr))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-getpwnam,getpwname_auth))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-ncsa,ncsa_auth))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-smb,smb_auth))